15.00 - Main Window - System Emulation Tool

Teradata System Emulation Tool User Guide

prodname
System Emulation Tool
vrm_release
15.00
category
User Guide
featnum
B035-2492-034K

Main Window

The main window (Figure 2) contains menus, commands, and a toolbar that access Teradata SET primary functions and features. Use the options available in the main window to navigate the Teradata SET application.

Figure 2: Teradata SET Main Window

Table 4 describes the main window options. Table 5 explains the information available in the About Teradata System Emulation Tool dialog box, which is accessed from the Help menu.

 

Table 4: Main Window Menus, Commands, and Toolbar Buttons 

Menu

Command

Button

Description

File

 

Connect

Log on to a Teradata Database.

Disconnect

Log off from a Teradata Database.

Exit

None

Close Teradata Set and return to the Windows desktop.

View

 

Log File

Open or close a log file.

 

Summary Report

Open or close a report that summarizes the successes and failures of an import, export, or undo import (cleanup) operation.

 

Font

None

Display the Font dialog box to change the font style, size, or color for text displayed in the main window. For example, change the font used when displaying the log file or summary report.

 

Toolbar

None

Show or hide the main window toolbar.

 

Status Bar

None

Show or hide the status bar in the main and Import windows.

Tools

 

Export

Capture emulation information from a target system.

 

Import

Open the Import window, edit exported emulation information, and then import that information to a test system.

 

Undo Import

Display the Open dialog box and select a single .undo file of imported information to remove it from a test system.

 

Customize Data

Open the Import window, select an .mcf file, then edit emulation information without being connected to Teradata Database.

Note: This option is only available when not connected.

 

Set TLE

Display the Set Target Level Emulation dialog box to define how RAS, cost parameters, cost profiles, and Dynamic (IPE) plans are emulated on the connected system.

 

Reset TLE

Display the Reset Target Level Emulation dialog box to reset RAS, cost parameters, and cost profiles to default values.

 

Delete Files

Display the Delete dialog box to remove selected Teradata SET files. The .mcf files are read and, depending on the export options chosen, the corresponding file types (such as .ddl and .opt) are removed. See “Perform File Management” on page141 .

 

Pack

Display the Pack dialog box to combine an .mcf file and its associated files into one file (.pack). The UDF code files specified (if any) in response to the “Browse for UDF” File Open Dialog during export are also packed in the same file. See “Perform File Management” on page141 .

 

Unpack

Display the Unpack dialog box to separate the files in a .pack file. See “Perform File Management” on page141 .

 

Define Data Source

None

Display the ODBC Database Administrator dialog box to define or edit ODBC data sources for a Teradata Database.

 

Execute SQL/SQL Assistant

Open a query editor (SQL Assistant or Execute SQL) to execute queries. Click Tools>Options to select an editor.

 

Options

None

Display the Options dialog box to customize Teradata SET features. See “Customization Options” on page51 .

Help

 

Help Topics

Open online help.

 

About Teradata System Emulation Tool

None

Display version and copyright information.

Note: From the main window, click Help>About Teradata System Emulation Tool. The About Teradata System Emulation Tool dialog box appears. See Table 5 .

Toolbar button

None

None

Toggle audible notification feature on or off.

Note: Control of this feature is also accessible from Tools > Options. Select the Customize tab.

 

Table 5: Version and Copyright Information 

Information

Description

Version

Version number of the software installed.

Date Created

Date the installed version of software was created.

System

System name of the current connection.

Note: This information appears only when connected to a Teradata Database.

Connection Type

The connectivity type is indicated as the following types:

  • Connected-ODBC - connected to Teradata Database with ODBC connectivity
  • Connected-CLI - connected to Teradata Database with CLI connectivity
  • Not Connected - not connected to Teradata Database
  • Character Set

    Displays the session character set used to connect to Teradata Database.

    Note: This information appears only when connected to a Teradata Database.

    User

    Name of the currently connected user.

    Note: This information appears only when connected to a Teradata Database.

    Database Version

    Version number of the connected Teradata Database.

    Note: This information appears only when connected to a Teradata Database.

    Database Release

    Release number of the connected Teradata Database.

    Note: This information appears only when connected to a Teradata Database.

    Copyright

    Current copyright statement.