System Requirements | Teradata Package for Python 17.00.00.04 - 17.00 - Teradata Package for Python System Requirements - Teradata Package for Python

Teradata® Package for Python User Guide

Product
Teradata Package for Python
Release Number
17.00
Release Date
November 2021
Content Type
User Guide
Publication ID
B700-4006-070K
Language
English (United States)

Required Software on Teradata Vantage

Based on the connection to Vantage, the teradataml package requires the following minimum software versions be installed on Vantage:

Teradata Vantage with Advanced SQL Engine Release 16.20.16.01 or later

  • For connection to Teradata Vantage with Advanced SQL Engine only:
    • On Advanced SQL Engine:

      Advanced SQL Engine 16.20.16.01 or later versions

  • For connection to Teradata Vantage with Advanced SQL Engine and ML Engine:
    • On Advanced SQL Engine:

      Advanced SQL Engine 16.20.16.01 or later versions

    • On ML Engine:

      ML Engine 08.00.03.00 or later

Required Software on Client

The teradataml package also requires a minimum version of the following software be installed on the client:

  • teradatasqlalchemy 17.00.00.02
  • teradatasql 17.00.00.07
  • pandas 0.22.00
  • psutil
  • Operating Systems:
    • Windows OS: Windows 7
    • macOS: os x 10.9
    • Linux: Ubuntu 16.04, CentOS 7.0, RHEL 7.1, or SLES 12
    The teradataml package only supports 64-bit version of these operating systems.

Compatible Development Environment

The following third party Integrated Development Environment (IDE) and data science user interface (UI) tool is compatible with Teradata Package for Python:

  • Jupyter