Gateway Message 08059 - 17.10 - 08059 - Advanced SQL Engine - Teradata Database

Teradata Vantageā„¢ - Database Messages

Product
Advanced SQL Engine
Teradata Database
Release Number
17.10
Release Date
July 2021
Content Type
Programming Reference
Publication ID
B035-1096-171K
Language
English (United States)
Message
Advanced SQL Engine is configured to accept TLS encrypted connections only. %s
Explanation
When the gateway is configured with TLS set to 'required', connections are required to use TLS. The gateway listens to both the HTTPS port and the legacy port and only accepts a new TLS connection through the HTTPS port. Gateway will return an error to the client application if it receives a legacy connection request from the legacy port.
Generated By
Gateway
For Whom
Client Interface, End User
Notes
None
Remedy
Reconnect to the gateway using TLS port. Alternatively, the TLS setting can be configured to 'nolegacy' to disable connections on legacy port on server. Alternatively, the TLS setting can be configured to 'enable' to allow connections on both HTTPS and legacy ports on server. For 17.10+ clients, set connection SSLMODE to a TLS compatible value. If unsuccessful, contact your Teradata database administrator. For pre-17.10 clients, upgrade to TTU 17.10 or later version and set connection SSLMODE to a TLS compatible value. If unsuccessful, contact your Teradata database administrator.