16.20 - Installing the Ecosystem Manager Client Package on Linux (Non-Teradata Managed) - Teradata Ecosystem Manager

Teradata® Ecosystem Manager Installation, Configuration, and Upgrade Guide for Customers

prodname
Teradata Ecosystem Manager
vrm_release
16.20
created_date
December 2020
category
Configuration
Installation
featnum
B035-3203-107K
In addition to installing the client package as described here, Ecosystem Manager provides a REST API for installation and configuration of certain types of publisher and agent client packages. For reference, go to: http://EM server host:port/swagger-ui.html#!/server-controller/updateServerUsingPUT. For example: http://wario:8090/swagger-ui.html#!/server-controller/updateServerUsingPUT. For API examples, see: Teradata® Ecosystem Manager API Reference.
  1. Install JDK/JRE 1.8 if not installed.
    1. Download the teradata-jdk8__sles_x8664.1.8.0_xx-tdc2.tar.gz package.
    2. Extract the package:
      tar -xvf teradata-jdk8__sles_x8664.1.8.0_xx-tdc2.tar.gz
    3. Install the package:
      rpm -uvh teradata-jdk8-1.8.0_xx-tdc2.x86_64.rpm
  2. Download the Client Packages to a folder on the server.
  3. Extract the files:
    tar -xvf em-publisher-linux64__linux_x86_64.16.20.xx.xx-1.tar.gz

    tar -xvf em-agent-linux64__linux_x86_64.16.20.xx.xx-1.tar.gz

  4. Locate the following rpm packages:
    em-publisher-16.20.xx.xx-1.x86_64.rpm

    em-agent-16.20.xx.xx-1.x86_64.rpm

  5. Install the rpm packages in the /opt/teradata/client/em file.
    rpm -ivh em-publisher-16.20.xx.xx-1.x86_64.rpm

    rpm –ivh em-agent-16.20.xx.xx-1.x86_64.rpm

  6. Run the script to configure the Ecosystem Manager services parameters:
    /opt/teradata/client/em/bin/emserviceconfig.sh
    Parameters:
    • JRE HOME (1.8)
    • PRIMARY EM SERVER HOSTNAME(BROKER)
    • FAIL-OVER EM SERVER HOSTNAME(BROKER)
    • ECOSYSTEM ID
    • RESOURCE SUB-CATEGORY
    For single-system environments, use the same value for the Primary and Fail-Over Server Hostname parameters. For servers, use one of the following values:
    Value Description
    RS Replication
    BI Business Intelligence
    BAR Backup, Archive, and Restore
    LS Load
    TD Teradata
    APP Application
    ETL Extract/Transform/Load
    BUS Message Bus
    Unknown Self-registered
    USL Unity Source Link
    The following example shows svr1 and svr2 as Ecosystem Manager servers, eco1 is the ecosystem, and APP is the resource sub-category:

    /opt/teradata/client/em/bin/emserviceconfig.sh /usr/java/jre1.8.0_18 svr1 svr2 eco1 APP

    This sets the parameters as follows:

    Parameter Setting
    JRE HOME (1.8) /usr/java/jre1.8.0_18
    PRIMARY EM SERVER HOSTNAME(BROKER) svr1
    FAIL-OVER EM SERVER HOSTNAME(BROKER) svr2
    ECOSYSTEM ID eco1
    RESOURCE SUB-CATEGORY APP
  7. Disable TPT operational metadata delivery .
  8. Check the status of the Ecosystem Manager services:
    /opt/teradata/client/em/emstatus.sh
  9. Stop the Ecosystem Manager Services on the Linux server:
    /opt/teradata/client/em/emstopall.sh
    If the Linux package is installed on a Data Mover server, restart both Data Mover services (daemon and agent) for integration.
  10. [Optional] For Red Hat 7.x, if the installation of em-publisher-16.20.12.xx-1.x86-64.rpm or later fails, follow these steps.
    1. Verify the following error message appears:
      error: Failed dependencies:
              libc.so.6 is needed by em-publisher-16.20.12.00-1.x86_64
              libc.so.6(GLIBC_2.0) is needed by em-publisher-16.20.12.00-1.x86_64
              libc.so.6(GLIBC_2.1) is needed by em-publisher-16.20.12.00-1.x86_64
              libc.so.6(GLIBC_2.1.3) is needed by em-publisher-16.20.12.00-1.x86_64
              libc.so.6(GLIBC_2.2) is needed by em-publisher-16.20.12.00-1.x86_64
              libgcc_s.so.1 is needed by em-publisher-16.20.12.00-1.x86_64
              libgcc_s.so.1(GCC_3.0) is needed by em-publisher-16.20.12.00-1.x86_64
              libnsl.so.1 is needed by em-publisher-16.20.12.00-1.x86_64
              libstdc++.so.6 is needed by em-publisher-16.20.12.00-1.x86_64
              libstdc++.so.6(CXXABI_1.3) is needed by em-publisher-16.20.12.00-1.x86_64
              libstdc++.so.6(GLIBCXX_3.4) is needed by em-publisher-16.20.12.00-1.x86_64
              libstdc++.so.6(GLIBCXX_3.4.5) is needed by em-publisher-16.20.12.00-1.x86_64
              libuuid.so.1 is needed by em-publisher-16.20.12.00-1.x86_64
      
    2. Install the missing dependencies with these commands:
      yum install glibc.i686
      yum install glibc-devel.i686
      yum install libstdc++.i686
      yum install libuuid.i686
      yum install dos2unix
      
    3. Re-install the em-publisher package.