クエリー開発のFAQ - Teradata Studio

Teradata® Studio™ ユーザー ガイド

Product
Teradata Studio
Release Number
20.00
Published
2023年10月
Language
日本語
Last Update
2024-02-10
dita:mapPath
ja-JP/sbf1696897640614.ditamap
dita:ditavalPath
ft:empty
dita:id
kvj1467315192096
Product Category
Teradata Tools and Utilities

どうすればTeradata Studio/Studio Expressでクエリーを実行できますか?

Teradata Studio/Studio ExpressでSQL文を入力しクエリーを実行するには、以下を行ないます。
  1. 次のいずれかを実行して、Teradata SQLエディタを開きます。
    • データ ソース エクスプローラで接続プロファイルを選択し、""をクリックします。
    • ファイル > 新規SQLエディタに移動し、SQLエディタのドロップダウンから接続プロファイルを選択します。
  2. エディタにSQL文を入力します。
  3. 次のいずれかを実行して、SQL文を実行します。
    • 単一の文では""をクリックします。
    • 複数の文では""をクリックします。
    • SQLエディタを右クリックし、単一文では実行を選択します。
    • SQLエディタを右クリックし、複数の文ではすべて実行を選択します。
    • Ctrl+ALT+Xキーを使用します。

Teradata Studio/Studio Expressでは、SQLエディタのSQL文の構文をチェックしますか?

はい。Teradata Studio/Studio ExpressではSQLエディタに入力したSQL文を解析します。構文エラーがあると、赤い下線が付けられます。下線が付いた単語にカーソルを合わせると、予想される単語のリストが開きます。エラーを無視して、引き続きSQL文を実行することもできます。

Teradata Studio/Studio Expressでは、SQLエディタ接続プロファイルドロップダウン リストで選択したデータベースのバージョンの文法を使用して、文を検証します。

どうすればSQLエディタからクエリーをクリアできますか?

SQLエディタのツールバーから""をクリックして、すべてのクエリーをクリアします。

どうすればSQLエディタで行番号を表示できますか?

SQLエディタの左余白を右クリックし、行番号の表示を選択します。

どうすれば、SQLエディタから選択した行のみを実行できますか?

SQLエディタからテキストを右クリックし、選択したテキストの実行を選択します。

どうすればSQLテンプレートをSQLエディタに追加できますか?

SQLテンプレートを追加するには以下を行ないます。
  1. 要素の先頭に移動します。
  2. Ctrl+Spaceキーを使用します。ダイアログ ボックスにSQLテンプレートのリストが表示されます。
  3. SQL文に追加するテンプレートを選択します。

クエリーで名前付きパラメータを使用できますか?

はい、クエリーで名前付きパラメータを使用できます。

例えば、クエリーSELECT * FROM db.customer WHERE region = ?\region;を実行しリージョン パラメータの値をパラメータの構成 ダイアログ ボックスに入力できます。

どうすれば、クエリーに関する音声通知を提供できますか?

クエリーに関する音声通知を提供するには以下を行ないます。
  1. ウィンドウ > 設定 > Teradataデータツール > SQLの処理へ移動します。
  2. サウンドタブを選択します。
  3. 成功サウンドと失敗サウンドをシステム ビープまたはサウンドの選択に設定します。
    サウンドの選択の場合、システムからサウンド ファイルを参照して選択する必要があります。

どうすればクエリーのフォントを変更できますか?

クエリーのフォントを変更するには以下を行ないます。
  1. ウィンドウ > 設定 > 一般 > 外観 > 色とフォントへ移動します。
  2. 基本を展開し、以下を選択します。
    • テキスト フォント: SQLエディタのフォントを編集します。
    • ダイアログのフォント: Teradata結果セット ビューアのフォントを編集します。
  3. 編集をクリックして、必要に応じてフォントを編集します。
  4. OKをクリックして変更を保存します。
  5. 適用をクリックします。
    フォントを復元するには、色とフォントウィンドウでデフォルトの復元をクリックします。

SQLクエリーのフォーマットはどこで変更できますか?

ウィンドウ > 設定 > Teradataデータツール > SQLフォーマッタに移動して、フォーマット オプションを変更します。

SQLクエリーの構文の色はどこで変更できますか?

ウィンドウ > 設定 > データ管理 > SQLの作成 > SQLエディタ > 構文の色に移動し、構文オブジェクトの色を変更します。

どうすれば、SQLエディタの概要ビューを開けますか?

概要ビューを開くには以下を行ないます。
  1. ウィンドウ > ビューの表示に移動して概要をクリックします。概要ビューが画面の下部に表示されます。
  2. 概要ビューをクリックしながらSQLエディタの右端までドラッグします。
  3. 概要ビューからSELECT文を選択します。対応するSQL文がSQLエディタウィンドウでハイライト表示されます。

どうすれば、SQLエディタで長方形選択に切り替えられますか?

SQLエディタをクリックし、SHIFT+ALT+Aキーを使用して長方形選択(列モード選択)に切り替えます。再びSHIFT+ALT+Aキーを使用すると、通常のモード選択に戻ります。

どうすれば、SQLエディタで既存のSQLファイルを開けますか?

既存のSQLファイルをプロジェクト エクスプローラにインポートまたはドラッグできます。
  • SQLファイルをインポートするには以下を行ないます。
    1. ファイルに移動し、インポートをクリックしてインポートダイアログ ボックスを開きます。
    2. 一般 > ファイル システムを選択します。
    3. 次へをクリックします。
    4. システム内にあるSQLファイル ディレクトリを参照します。
    5. 右側のペインから必要なSQLファイルを選択します。
    6. Teradata Studio/Studio Expressワークスペースを参照して、SQLファイルのインポート先となるプロジェクト フォルダの場所を特定します。
    7. 終了をクリックします。インポートされたSQLファイルがプロジェクト エクスプローラに表示されます。
    8. SQLファイルを右クリックして、開く方法 > Teradata SQLエディタを選択します。SQLファイルがSQLエディタで開きます。
  • 既存のSQLファイルをドラッグするには以下を行ないます。
    1. システムのSQLファイル ディレクトリを開きます。
    2. ファイルをプロジェクト エクスプローラにドラッグします。ファイルの操作ダイアログ ボックスが表示されます。
    3. ファイルをコピーをクリックします。SQLファイルがプロジェクト エクスプローラに表示されます。
    4. SQLファイルを右クリックして、開く方法 > Teradata SQLエディタを選択します。SQLファイルがSQLエディタで開きます。

どうすればSQLファイルを比較できますか?

SQLファイルを比較するには以下を行ないます。
  1. プロジェクト エクスプローラビューに移動します。
  2. Ctrlキーを使用して複数のSQLファイルを選択します。
  3. 右クリックして、比較 > 相互を選択します。

比較エディタでSQLファイルが開き、横並びに表示されたファイルを比較するためのツールバー ボタンで違いを確認できます。

どうすれば、SQLクエリーを外部SQLファイルに保存できますか?

SQLクエリーを外部SQLファイルに保存するには以下を行ないます。
  1. SQLエディタツールバーで、""の横にあるドロップダウン矢印をクリックします。
  2. ファイル システムへのエクスポートを選択します。ファイルに保存ダイアログ ボックスが表示されます。
  3. システムからディレクトリを指定します。
  4. 保存をクリックします。

どうすれば結果セット データをファイルに保存できますか?

結果セットのデータを保存するには、2つのオプションがあります。結果セットのデータをファイル システムに保存(エクスポート)するか、またはワークスペースに保存されるファイルに保存(保存)できます。

結果セット ビューアツールバーから""または""をクリックし、結果セット データを保存するファイルの名前を選択します。

どうすれば結果セット データをファイルに自動でエクスポートできますか?

詳細については、SQL処理設定の設定を参照してください。