データベース接続のFAQ - Teradata Studio

Teradata® Studio™ ユーザー ガイド

Product
Teradata Studio
Release Number
20.00
Published
2023年10月
Language
日本語
Last Update
2024-02-10
dita:mapPath
ja-JP/sbf1696897640614.ditamap
dita:ditavalPath
ft:empty
dita:id
kvj1467315192096
Product Category
Teradata Tools and Utilities

Teradata Studio/Studio Expressはどのようにデータベースに接続しますか?

Teradata Studio/Studio Expressは、JDBCを使用してTeradata Database、Aster Database、またはHadoopシステムに接続します。ODBCはTeradata Studio/Studio Expressではサポートされません。Teradata JDBCドライバ、Aster JDBCドライバ、およびHiveServer2(v0.13)JDBCドライバは、Teradata Studio/Studio Express製品に組み込まれています。詳細については、データベースの接続を参照してください。

どうすればStudio Expressでユーザーのパスワードを変更できますか?

Teradata Studio/Studio Expressでユーザーのパスワードを変更するには以下を行ないます。
  1. データ ソース エクスプローラツリーからデータベース ノードを右クリックします。
  2. Teradata > パスワードの変更へ移動します。
  3. 現在のパスワード、新しいパスワード、確認用の新しいパスワードをそれぞれのフィールドに入力します。
  4. OKをクリックします。

どうすればTeradata以外のデータベースに接続できますか?

Teradata Studio/Studio Expressは、DB2データベース、Oracleデータベース、またはSQL Serverデータベースに接続できます。新規プロファイル接続タイプ(ウィンドウ > 設定 > Teradataデータツール > 新規プロファイル接続タイプ)からデータベースの種類を選択して、接続タイプを有効にします。新しい接続プロファイルの作成に進むと、選択したTeradata以外のデータベースが接続プロファイルのタイプに表示されます。詳細については、データベースの接続を参照してください。

どうすればデータベースを追加できますか?

Teradata Studio/Studio Expressでは、データ ソース エクスプローラビューに表示されるデータベース ツリーに、データベース、テーブル、マクロ、ビューなどのデータベース オブジェクトがフォルダの中に含まれています。

データベースを追加するには、以下の手順を行ないます。
  1. ウィンドウ > 設定 > Teradataデータツール > データ ソース エクスプローラのロードへ移動します。
  2. データベースの表示階層表示のユーザーの選択を解除します。
  3. ユーザーの選択を選択します。
  4. 適用をクリックします。
  5. データ ソース エクスプローラビューに移動し、データベースフォルダを右クリックします。
  6. Teradata > データベースのロードを選択します。データベースの追加ダイアログ ボックスが表示されます。
  7. データベースの名前を入力します。
  8. 追加をクリックします。新しいデータベースがデータベースフォルダの下に表示されます。

データベース ツリーのルートの場所を設定する理由と方法は?

データベース ツリーを階層形式(ネストされた子データベースとユーザー)で表示しながら、ツリーに表示されるデータベースとユーザーの数を減らしたい場合は、データベース ツリーのルートを設定できます。これにより、ツリーの表示が自分のデータベースまたはユーザーとその子データベースおよびユーザーに制限されます。

データ ソース エクスプローラでデータベース ツリー フィルタを作成する理由と方法は?

データ ソース エクスプローラのフォルダにフィルタを設定して、不要なデータベース オブジェクトを除外できます。このフィルタは、テーブル、ビュー、ストアド プロシージャ、およびユーザー定義による関数にも適用されます。

フィルタを作成するには以下の手順を行ないます。
  1. データ ソース エクスプローラ ビューでフォルダを右クリックし、フィルタを選択します。フィルタ ダイアログ ボックスが表示されます。
  2. フィルタを無効にするの選択を解除します。
  3. 次のいずれかを選択して、フィルタを設定します。
    • : 名前ドロップダウン メニューの式でフィルタリングします。
    • 選択: 表示に含めるか除外するオブジェクトをリストから選択します。
  4. OKをクリックして、データ ソース エクスプローラ ビューでフィルタを適用します。

接続プロファイルをインポートおよびエクスポートする方法

  1. インポート: 以前にStudio/Studio Expressからエクスポートされた接続プロファイル ファイルから接続プロファイルをインポートします。データ ソース エクスプローラまたはナビゲータで、をクリックします。インポート元のファイルのパスを指定します。
    インポートする接続プロファイルは、新しい接続プロファイル ウィザードを使用して作成できるタイプである必要があります。システムは、サポートされていないタイプの接続プロファイルを破棄します。
  2. エクスポート: 接続プロファイルをエクスポートします。データ ソース エクスプローラまたはナビゲータで、をクリックします。エクスポートする接続をリストから選択します。接続プロファイルをファイル システムに保存するために使用するファイル パスを指定します。デフォルトでは、ファイルの内容を暗号化するチェックボックスが有効になっています。これにより、エクスポートされた接続プロファイル ファイルの暗号化が有効になります。
    暗号化せずに接続プロファイルをエクスポートすることを選択した場合、接続プロファイルの詳細はファイル内にプレーン テキストとして表示されます。