17.10 - Load/Export Utility Requirements - Advanced SQL Engine - Teradata Database

Teradata Vantage™ - Advanced SQL Engine Security Administration

Product
Advanced SQL Engine
Teradata Database
Release Number
17.10
Release Date
July 2021
Content Type
Administration
Security
Publication ID
B035-1100-171K
Language
English (United States)

Load utilities that support the creation of database target tables as part of the job script also support the definition of security constraint columns in the target tables. TPump error table and Acquisition error tables for MultiLoad/FastLoad are not protected. However, Application error tables for MultiLoad/FastLoad are protected.

If the user does not have OVERRIDE privileges on a constraint when inserting into or updating a table, constraint column values default to the session constraint values for the user.

Granting OVERRIDE privileges to a user prevents execution of the corresponding row level security constraint UDF(s), and allows the user to specify the constraint values.

Users with OVERRIDE privileges must specify the values for non-hierarchical constraint columns as hex code instead of numeric values. See Specifying Non-Hierarchical Constraint Values when Loading Tables.