System Requirements | Teradata Package for Python 17.20.00.04 - Teradata Package for Python System Requirements - Teradata Package for Python

Teradata® Package for Python User Guide

Deployment
VantageCloud
VantageCore
Edition
Enterprise
IntelliFlex
VMware
Product
Teradata Package for Python
Release Number
20.00
Published
March 2024
Language
English (United States)
Last Update
2024-04-09
dita:mapPath
nvi1706202040305.ditamap
dita:ditavalPath
plt1683835213376.ditaval
dita:id
rkb1531260709148
Product Category
Teradata Vantage

Required Software on Teradata Vantage

Based on the connection to Vantage, the teradataml package requires the following minimum software versions be installed on Vantage:

Teradata Vantage with database release 16.20.16.01 or later or VantageCloud Lake.

Required Software on Client

The teradataml package requires a minimum version of the following software be installed on the client:

  • Operating Systems:
    • Windows OS: Windows 7
    • macOS: os x 10.9
    • Linux: Ubuntu 16.04, CentOS 7.0, RHEL 7.1 with gcc 5.5, or SLES 12
    The teradataml package only supports 64-bit version of these operating systems.
  • Dependent packages:
    • teradatasqlalchemy 20.00.00.00
    • teradatasql 17.10.00.11
    • SQLAlchemy 1.4.44
      teradataml 17.20.00.03 version only supports SQLAlchemy 1.4.

      teradataml 17.20.00.04 version works with both SQLAlchemy 1.4.x and 2.0.x.

      See SQLAlchemy Compatibility Considerations for important notes when using sqlalchemy 2.0 and later.

    • pandas 0.22.00
    • psutil
    • scikit-learn >= 0.24.2
    • IPython >= 8.10.0
    • imbalanced-learn >= 0.8.0