System Requirements | Teradata Package for R 17.00.00.04 - Teradata Package for R System Requirements - Teradata Package for R

Teradata® Package for R User Guide

Deployment
VantageCloud
VantageCore
Edition
Enterprise
IntelliFlex
VMware
Product
Teradata Package for R
Release Number
17.20
Published
March 2024
Language
English (United States)
Last Update
2024-04-09
dita:mapPath
efv1707506846369.ditamap
dita:ditavalPath
ayr1485454803741.ditaval
dita:id
nqx1518630623256
Product Category
Teradata Vantage

Required Software on Teradata Vantage

Based on the connection to Vantage, the tdplyr package requires the following minimum software versions be installed on Vantage:

Teradata Vantage with Analytics Database Release 16.20.16.01 or later.

Required Software on Client

The tdplyr package requires a minimum version of the following software be installed on the client:

  • Operating Systems:
    • Windows OS: Windows 7
    • macOS: OS X 10.9
    • Linux: Ubuntu 16, CentOS or RHEL 7, SLES or openSUSE 12
    The tdplyr package only supports 64-bit version of these operating systems.
  • Dependent R packages:
    • DBI (>= 1.0.0)
    • dplyr (>= 1.1.0)
    • dbplyr (>= 2.3.2)
    • jsonlite (>= 1.7)
    • magrittr (>= 1.5)
    • teradatasql for R (>= 17.20.0.26)
    • rlang
    • bit64
    • purr
    All the dependent packages will be installed (if not present) or upgraded to latest versions (if the version is less than minimum version) along with tdplyr installation.

Compatible Development Environment

The following third party Integrated Development Environment (IDE) and data science user interface (UI) tools are compatible with Teradata Package for R:

  • RStudio
  • R Console
  • Jupyter