System Requirements | teradatamlspk Package 20.00.00.00 - teradatamlspk Package System Requirements - Teradata Package for Python

Teradata® pyspark2teradataml User Guide

Deployment
VantageCloud
VantageCore
Edition
Enterprise
IntelliFlex
VMware
Product
Teradata Package for Python
Release Number
20.00
Published
March 2024
Language
English (United States)
Last Update
2024-04-11
dita:mapPath
oeg1710443196055.ditamap
dita:ditavalPath
ayr1485454803741.ditaval
dita:id
oeg1710443196055
Product Category
Teradata Vantage

Required Software Teradata Vantage

The teradatamlspk package supports the following Vantage systems:
  • VantageCloud Lake
  • VantageCloud Enterprise
  • VantageCore

Based on the connection to Vantage, the teradatamlspk package requires the following minimum software versions be installed on Vantage:

For connection to Teradata Vantage with Analytics Database only:
  • On Analytics Database:
    • For VantageCore system, Analytics Database 17.20 or later
    • For VantageCloud Enterprise system, Analytics Database 17.20 or later
    • For VantageCloud Lake system, Analytics Database 20.00 or later

Required Software on Client

The teradatamlspk package requires a minimum version of the following software be installed on the client:

Python version
  • 3.8 or later
Dependent Python Packages
  • teradataml 20.0.0.0 or Later
  • PrettyTable
Operating Systems:
  • Windows 7 (64Bit) or later
  • macOS 10.9 (64Bit) or later
  • Red Hat 7.1 or later versions with gcc 5.5 and later versions
  • Ubuntu 16.04 or later versions
  • CentOS 7 or later versions
  • SLES 12 or later versions