System Requirements | Teradata R Package 17.00.00.00 - 17.00 - Teradata R Package System Requirements - Teradata R Package

Teradata® R Package User Guide

prodname
Teradata R Package
vrm_release
17.00
created_date
November 2020
category
User Guide
featnum
B700-4005-090K

Required Software on Teradata Vantage

Based on the connection to Vantage, the tdplyr package requires the following minimum software versions be installed on Vantage:

  • For connection to Vantage with Advanced SQL Engine only:
    • On Advanced SQL Engine:

      Advanced SQL Engine 16.20.16.01 or later versions

  • For connection to Vantage with Advanced SQL Engine and ML Engine:
    • On Advanced SQL Engine:

      Advanced SQL Engine 16.20.16.01 or later versions

    • On ML Engine:

      ML Engine 08.00.03.00 or later

Required Software on Client

The tdplyr package requires a minimum version of the following software be installed on the client:

  • Teradata SQL Driver for R: version 17.0.0.4
  • Operating Systems:
    • Windows OS: Windows 7
    • macOS: OS X 10.9
    • Linux: Ubuntu 16, CentOS or RHEL 7, SLES or openSUSE 12
    The tdplyr package only supports 64-bit version of these operating systems.

Compatible Development Environment

The following third party Integrated Development Environment (IDE) and data science user interface (UI) tools are compatible with Teradata R Package:

  • RStudio
  • R Console
  • Jupyter