Teradata System Compatibility | Teradata Data Mover - 17.05 - Database Compatibility - Teradata Data Mover

Teradata® Data Mover Compatibility Matrix

prodname
Teradata Data Mover
vrm_release
16.00
16.10
16.20
17.00
17.05
created_date
October 2020
category
Configuration
Installation
featnum
B035-6502-040K
Database Version Data Mover
17.05 17.00 16.20+
Advanced SQL Engine 17.05 Yes No No
Advanced SQL Engine 17.00+ Yes Yes No
Advanced SQL Engine 16.20+ Yes Yes Yes*
Teradata Database 16.10+ Yes Yes Yes
Teradata Database 15.10+ Yes Yes Yes
Teradata Database 15.00+ No Yes Yes
Teradata Database 14.10+ No No Yes
  • Data Mover 16.20.00 comes installed with ARC 16.20.00.02. However, ARC 16.20.00.02 is not compatible with Vantage. You must perform an in-place upgrade to ARC 16.20.00.04 or upgrade to Data Mover 16.20.12.00 or later. See KB0023567 at https://support.teradata.com.
  • Support for Teradata Database 16.00.xx.xx has been dropped for all versions of Data Mover.

Data Mover 17.05 Supported Copy Methods

Source Database Target Database
Advanced SQL Engine 17.05 Advanced SQL Engine 17.00 Advanced SQL Engine 16.20+ Teradata Database 16.10+ Teradata Database 15.10+
Advanced SQL Engine 17.05
  • DSA
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
Advanced SQL Engine 17.00
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
Advanced SQL Engine 16.20+
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
Teradata Database 16.10+
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
Teradata Database 15.10+
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • ARC is no longer supported as a copy method as of Data Mover 17.00.
  • For database versions earlier than 16.00, DSA is only available when the force_utility is specified as DSA.

Data Mover 17.00 Supported Copy Methods

Source Database Target Database
Advanced SQL Engine 17.00 Advanced SQL Engine 16.20+ Teradata Database 16.10+ Teradata Database 15.10+ Teradata Database 15.00+
Advanced SQL Engine 17.00
  • DSA
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
Advanced SQL Engine 16.20+
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
Teradata Database 16.10+
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
Teradata Database 15.10+
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • DSA
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
Teradata Database 15.00+
  • DSA
  • TPT
  • JDBC
  • DSA
  • TPT
  • JDBC
  • DSA
  • TPT
  • JDBC
  • DSA
  • TPT
  • JDBC
  • DSA
  • TPT
  • JDBC
  • ARC is no longer supported as a copy method as of Data Mover 17.00.
  • The QueryGrid Teradata to Teradata (T2T) connector is supported in Teradata Database 15.10.00 or later.
  • For database versions earlier than 16.00, DSA is only available when the force_utility is specified as DSA.

Data Mover 16.20 Supported Copy Methods

Source Database Target Database
Advanced SQL Engine 16.20+ Teradata Database 16.10+ Teradata Database 15.10+ Teradata Database 15.00+ Teradata Database 14.10+
Advanced SQL Engine 16.20+
  • ARC
  • DSA
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • TPT
  • JDBC
Teradata Database 16.10+
  • ARC
  • DSA
  • TPT
  • JDBC
  • T2T
  • ARC
  • DSA
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • TPT
  • JDBC
Teradata Database 15.10+
  • ARC
  • DSA
  • TPT
  • JDBC
  • T2T
  • ARC
  • DSA
  • TPT
  • JDBC
  • T2T
  • ARC
  • DSA
  • TPT
  • JDBC
  • T2T
  • TPT
  • JDBC
  • TPT
  • JDBC
Teradata Database 15.00+
  • ARC
  • DSA
  • TPT
  • JDBC
  • DSA
  • TPT
  • JDBC
  • DSA
  • TPT
  • JDBC
  • DSA
  • TPT
  • JDBC
  • TPT
  • JDBC
Teradata Database 14.10+
  • ARC
  • DSA
  • TPT
  • JDBC
  • ARC
  • DSA
  • TPT
  • JDBC
  • ARC
  • DSA
  • TPT
  • JDBC
  • ARC
  • DSA
  • TPT
  • JDBC
  • ARC
  • DSA
  • TPT
  • JDBC
  • Data Mover 16.20 comes installed with ARC 16.20.00.02. However, ARC 16.20.00.02 is not compatible with Vantage. You must perform an in-place upgrade to ARC 16.20.00.04 or upgrade to Data Mover 16.20.12.00 or later. See KB0023567 at https://support.teradata.com.
  • The QueryGrid Teradata to Teradata (T2T) connector is supported in Teradata Database 15.10.00 or later.
  • For database versions earlier than 16.00, DSA is only available when the force_utility is specified as DSA.