System Requirements | Teradata Data Mover - 17.05 - System Requirements - Teradata Data Mover

Teradata¬ģ Data Mover Compatibility Matrix

prodname
Teradata Data Mover
vrm_release
16.00
16.10
16.20
17.00
17.05
created_date
October 2020
category
Configuration
Installation
featnum
B035-6502-040K

Data Mover Server Requirements

Software Data Mover
17.05.00.00 17.00.00.00 16.20.50.00+
Operating System Teradata SUSE Linux Enterprise Server 12 SP3 or 11 SP3* Teradata SUSE Linux Enterprise Server 11 SP3 Teradata SUSE Linux Enterprise Server 11 SP3
Internal Repository Postgres 10.10 Advanced SQL Engine 16.20.00.00 Advanced SQL Engine 16.20.00.00
Development Tools ‚Äčteradata-jdk8-1.8.0_265-tdc4 and later
For non-Teradata servers, install or upgrade to JRE 8 before installing or upgrading any components.
teradata-jdk8-1.8.0_242-tdc1 and later
For non-Teradata servers, install or upgrade to JRE 8 before installing or upgrading any components.
teradata-jdk8-1.8.0_211-tdc1 and later
For non-Teradata servers, install or upgrade to JRE 8 before installing or upgrading any components.
TD ActiveMQ 5.15.9.0-1 5.15.9.0-1 5.15.9.0-1
The Data Mover 17.05.00.00 release supports the following:
  • For existing customers: Either Teradata SUSE 12 SP3 or 11 SP3 for on-premisis (IntelliFlex) customers. This is the last release supported for Teradata SUSE 11 SP3.
  • New orders of Data Mover 17.05 or later support Teradata SUSE 12 SP3.
  • Cloud (AWS, Azure, and Google Cloud) and VM deployments

Supported Operating Systems for Command Line on Non-Teradata Servers

Operating System Data Mover
17.05.00.00 17.00.00.00 16.20.50.00+
Centos Version 7.x, 6.x, and 8.x, 32 and 64 bit Version 7.x, 6.x, and 8.x, 32 and 64 bit Version 7.x and 6.x, 32 and 64 bit
IBM AIX Version 7.2 and 7.1, 64 bit Version 7.2 and 7.1, 64 bit Version 7.2 and 7.1, 64 bit
SUSE Linux Version 15 SP1, 32 and 64 bit

Version 12 SP1 and SP3, 32 and 64 bit

Version 11 SP3, 32 and 64 bit

Version 15, SP1, 32 and 64 bit

Version 12 SP1 and SP3, 32 and 64 bit

Version 11 SP3, 32 and 64 bit

Version 12 SP1 and SP3, 32 and 64 bit

Version 11 SP3, 32 and 64 bit

Oracle Enterprise Linux (OEL) Version 7.x, 6.x, and 8.x, 32 and 64 bit Version 7.x, 6.x, and 8.x, 32 and 64 bit Version 7.x and 6.x, 32 and 64 bit
Red Hat Linux Advanced Platform Version 7.x, 6.x, and 8.x, 32 and 64 bit Version 7.x, 6.x, and 8.x, 32 and 64 bit Version 7.x and 6.x, 32 and 64 bit
Ubuntu Linux Version 16.04 and 18.04, 64 bit Version 16.04 and 18.04, 64 bit Version 16.04 and 18.04, 64 bit
Microsoft Windows Version 2019, 64 bit

Version 16, 64 bit

Version 10, 32 and 64 bit

Version 2012 R2, 64 bit

Version 2012, 64 bit

Version 8.1, 32 and 64 bit

Version 2019, 64 bit

Version 16, 64 bit

Version 10, 32 and 64 bit

Version 2012 R2, 64 bit

Version 2012, 64 bit

Version 8.1, 32 and 64 bit

Version 16, 64 bit

Version 10, 32 and 64 bit

Version 2012 R2, 64 bit

Version 2012, 64 bit

Version 8.1, 32 and 64 bit

Version 7, 32 and 64 bit

Version 2008 R2, 32 and 64 bit

Solaris Sparc Version 11, 64 bit Version 11, 64 bit Version 10 and 11, 64 bit
Amazon Linux Amazon Linux, 64 bit

Amazon Linux 2, 64 bit

Amazon Linux, 64 bit

Amazon Linux 2, 64 bit

Amazon Linux, 64 bit

Amazon Linux 2, 64 bit

Install or upgrade to JRE8 before installing the command line.
Teradata does not acquire or install the appropriate Java JDK/JRE version to run the Data Mover command line on your non-Teradata platforms:
  • To use Oracle Java 8, you must have a license with Oracle to use it for commercial use.
  • An Azul Community Edition of JRE/JDK for Java 8 is available and routinely offers security patches.
  • The Azul Community Edition is approved for use on any platform that supports the Data Mover command line, except for IBM AIX.

Data Mover Command Line Compatibility

Data Mover Command Line Data Mover Backend
17.05 17.00 16.20+
17.05 Yes No No
17.00 No Yes No
16.20+ No No Yes

Data Mover Component Version Requirement

As of Data Mover 16.00, only the major and minor versions of the Data Mover daemon and the Data Mover command line interface must match. For instance:
Command Line Interface Daemon Version Supported
16.00.01.00 16.00.02.00 Yes
15.11.00.00 16.00.00.00 No
The Data Mover agent must be the exact same version as the Data Mover daemon.