15.00 - 5850 BEFORE statement triggers are not supported. - Teradata Database

Teradata Database Messages

Product
Teradata Database
Release Number
15.00
Content Type
Programming Reference
Publication ID
B035-1096-015K
Language
English (United States)

5850 BEFORE statement triggers are not supported.

Explanation:

In the ANSI trigger implementation of V2R5.1 , BEFORE Statement triggers are not allowed.

Generated By:

SYN, RES modules.

For Whom:

End user or Field Engineer or the concerned site support Representative.

Notes:

The BEFORE Statement triggers were supported in the original implementation of triggers from V2R3. But to ensure that triggers are ANSI complaint, the BEFORE Statement triggers are disallowed from V2R5.1

Remedy:

To prevent this error message, the application must be modified to use some alternative to the BEFORE Statement trigger. Most likely a BEFORE statement trigger can be replaced by an AFTER trigger.