16.20 - General Command Shortcut Keys - Teradata SQL Assistant

Teradata® SQL Assistant for Windows User Guide

Product
Teradata SQL Assistant
Release Number
16.20
Published
October 2018
Language
English (United States)
Last Update
2020-01-03
dita:mapPath
gfk1537201040714.ditamap
dita:ditavalPath
ft:empty

The following table lists the command shortcut keys available in SQL Assistant.

Shortcut Key Menu/Command Description
F1 N/A Displays context-sensitive help.
Ctrl+N File > New Query Clears the Query window for entry of new query.
Ctrl+O File > Open Query Opens the Open Query dialog.
Ctrl+S File > Save Saves the contents of the current window to a file.
Ctrl+P File > Print Prints the contents of the current window.
Ctrl+Y Edit > Redo Redoes a previously Undone change.
Ctrl+Z Edit > Undo Undoes the last change made in the active Query window.
Ctrl+X Edit > Cut Cuts the last change made in the active Query window.
Ctrl+C Edit > Copy Copies the last change made in the active Query window.
Ctrl+V Edit > Paste Pastes the last change made in the active Query window.
Ctrl+Q Edit > Format Query Formats the query in the Query window.
Ctrl+F Edit > Find Searches the active window for the desired text string.
F3 Edit > Find Next Finds the next occurrence of the string that was specified in the previous Find command.
Shift+F3 Edit > Find Previous Finds the previous occurrence of the string that was specified in the previous Find command.
Ctrl+H Edit > Replace Finds and replaces a particular string in the active window.
F4 Edit > Add Totals Displays totals at the bottom of numeric columns.
Ctrl+A Edit > Select All Selects everything in the current window.
Ctrl+G View > Go To Explorer Moves your cursor to the Database Explorer Tree.
F7 View > Previous SQL Moves the active cell in the History window to the previous row and copies the query from this new row into the Query window.
F8 View > Next SQL Moves the active cell in the History window to the next row and copies the query from this new row into the Query window.
F11 View > Last Error Displays the most recent SQL error message allowing you to see the full text of a message that is too long to fit on the status bar.
F5 Tools > Execute Submits the query that is currently in the Query window. Each statement in the query is submitted separately to the database.
F6 Tools > Explain Issues an EXPLAIN.
F9 Tools > Execute Parallel Submits the entire query that is currently in the Query window as a single request.
F10 Tools > Abort Aborts the currently executing query.
Shift+F10 or <Right-Click> N/A Display the context menu for this window.
F12 Window > Set Title Sets a title for an Answerset.