17.10 - Supported Kafka Server Versions - Access Module

Teradata® Tools and Utilities Access Module Reference

Product
Access Module
Release Number
17.10
Published
October 2021
Language
English (United States)
Last Update
2021-11-02
dita:mapPath
uur1608578381725.ditamap
dita:ditavalPath
obe1474387269547.ditaval

The Teradata Access Module for Kafka supports all versions of the Apache Kafka server, starting from 0.8.x.y

For Kafka server versions below 0.9.0.x, the following must be provided in the initialization string:

"-X api.version.request=false -X broker.version.fallback=a.b.c.d"

Where a.b.c.d represents the exact broker version.