17.10 - View Requirements - Advanced SQL Engine - Teradata Database

Teradata Vantage™ - Advanced SQL Engine Security Administration

Product
Advanced SQL Engine
Teradata Database
Release Number
17.10
Published
July 2021
Language
English (United States)
Last Update
2022-02-15
dita:mapPath
ppz1593203596223.ditamap
dita:ditavalPath
wrg1590696035526.ditaval
dita:id
zuy1472246340572

When a user accesses a view, the system enforces all security constraints in the base table(s) referenced by the view, whether or not the view contains the security constraint columns.

A CREATE VIEW or REPLACE VIEW statement can reference both RLS and non-RLS base tables, but all of the RLS base tables must contain the same security constraints or the system returns an error.

If you add or change security constraints in base tables referenced by a view, and as a result the RLS tables no longer contain matching sets of security constraints, subsequent requests to access the view fail with an error.