16.20 - Dependencias - Teradata Data Mover

Teradata® Data Mover Guía de instalación, configuración y actualizaciónpara clientes

prodname
Teradata Data Mover
vrm_release
16.20
created_date
Mayo de 2019
category
Administración
Configuración
Instalación
featnum
B035-4102-107K-ESN

Requisitos del servidor de Data Mover

Software Nivel
Sistema operativo SUSE Linux Enterprise Server 11 SP 3
Repositorio interno Teradata Database 16.20
Herramientas de desarrollo teradata-jdk8-1.8.0_211-tdc1 y posterior
Para los servidores que no son de Teradata, instale o actualice a JRE 8 antes de instalar o actualizar cualquiera de los componentes.

Requisito de versión de componentes de Data Mover

A partir de Data Mover 16.00, solo deben coincidir las versiones principal y secundaria del daemon de Data Mover y de la interfaz de línea de comandos o el portlet de Data Mover. Por ejemplo:
Versión del portlet o la interfaz de línea de comandos Versión del daemon Compatible
16.00.01.00 16.00.02.00
15.11.00.00 16.00.00.00 No
La versión del agente de Data Mover debe ser exactamente la misma que la versión del daemon de Data Mover.

Requisitos de componentes externos

Las versiones de los componentes con las que funciona Data Mover se enumeran a continuación.
Software Nivel
Teradata Database Versiones 14.10–16.20
Hortonworks Data Platform para hardware no especializado Versiones 2.4, 2.5 y 2.6
Hortonworks Data Platform para el dispositivo Teradata para Hadoop Versiones 2.4, 2.5 y 2.6
Conector de Teradata para Hadoop Versión 1.5.5
Teradata Aster Database Versión 6.20
Teradata Viewpoint Versiones 16.10 y 16.20
Distribución de Cloudera de Hadoop para hardware genérico Versiones 5.5, 5.7, 5.8, 5.9, 5.11, 5.12, 5.13, 5.14 y 5.15
Distribución de Cloudera de Hadoop para el dispositivo Teradata para Hadoop Versiones 5.5, 5.7, 5.8, 5.9, 5.11, 5.12, 5.13, 5.14 y 5.15
Data Stream Architecture (DSA externo)
A partir de Data Mover 16.20.25.00, se admite la versión actual de la versión de DSC integrada, así como lo siguiente:
  • Tres versiones de DSC anteriores.
  • Una versión de DSC posterior.
La versión principal y secundaria de la DSC incrustada y ClientHandler deben coincidir. El DSC incrustado admitirá las versiones actuales y tres anteriores de ClientHandler.
Para las versiones de Data Mover anteriores a 16.20.25.00, el DSC externo debe coincidir con la versión de DSA incluida con la versión Data Mover.

Permisos necesarios

Debe ser un usuario raíz para instalar y configurar los componentes de Data Mover.

Puertos abiertos obligatorios en el servidor de Data Mover

Los puertos TCP enumerados a continuación deben estar abiertos al tráfico entrante y saliente en el servidor de Data Mover:
Número de puerto Utilizado por
22 SSH
1025 ARC, TPTAPI y JDBC
1080 API RESTful HTTP
1443 API RESTful HTTPS
5180 y 5190 Administración del servidor
9090 API RESTful de DSA
25168 Servidor de ARC
25268 Módulo de acceso de ARC
25368 Servicio de sincronización activo
61616 ActiveMQ

Puertos abiertos para acceder a los servicios Hadoop

Los puertos enumerados a continuación son los puertos Hadoop predeterminados que se abren para que Data Mover pueda acceder a cada servicio Hadoop. Estos puertos son configurables en Hadoop.
Número de puerto Utilizado por
9083 Hive metastore
10000 JDBC DE HIVE
11000 Oozie
14000 HttpFS
50070 WebHDFS
50111 WebHCat

Required Open Ports to Access Aster

El puerto que aparece a continuación debe estar abierto en el nodo reina de Aster para Data Mover para acceder al sistema Aster:
Número de puerto Utilizado por
2406 Aster JDBC