17.20 - 250 EM_MUSTUSETLS TLS connection is required - Call-Level Interface Version 2 - Teradata Tools and Utilities

Workstation-Attached Call-Level Interface Version 2 (CLIv2) Messages

Product
Call-Level Interface Version 2
Teradata Tools and Utilities
Release Number
17.20
Published
June 2022
Language
English (United States)
Last Update
2022-10-10

250 EM_MUSTUSETLS TLS connection is required.

Explanation:

A non-TLS encrypted connection attempt was made to a server that is configured to only accept TLS connections. The server responded on the legacy port (1025) with error parcel ErrGTWMustUseTLS(8059). This indicates that the server is listening on the legacy port, but is not accepting connections on that port, only on the TLS port.

Remedy:

Retry the connection to the server using a sslmode that uses TLS (i.e. prefer, require, verify-ca, or verify-full).