16.20 - 転送履歴ビューについて - Teradata Studio

Teradata® Studio™ Express ユーザー ガイド

prodname
Teradata Studio
vrm_release
16.20
created_date
2019年3月
category
ユーザー ガイド
featnum
B035-2042-039K-JPN

Teradata転送履歴ビューには、データベースのデータ転送履歴情報の拡張表示が提供されます。データ転送が実行されると、エントリが転送履歴に置かれます。転送履歴ビューには、行またはセルを選択できるグリッド形式のデータが表示されます。

転送履歴ビューには、名前、開始時刻、転送された行、ソース システムおよび宛先システム、ステータス(完了、キャンセル、失敗)、サマリーなどのデータ転送イベントに関する広範な情報が提供されます。次を行なうオプションが提供されます。
  • 選択したセルをクリップボードにコピー
  • 列の並べ替え
  • 行の削除
  • 履歴エントリの「注記」または「名前」の編集
  • 列のフィルタ
  • 転送履歴データの検索
  • 列の非表示/表示
  • 列または行の自動サイズ変更
  • 履歴エントリのジョブ出力の表示

転送履歴ビューでは、転送履歴エントリの管理に埋め込みDerby Databaseが使用されます。

ビューを閉じた場合、ウィンドウ > ビューの表示 > 転送履歴ビューを選択してビューを開き直します。

転送履歴ビュー 注記エントリを選択して、ツールバーで 注記の編集をクリックし、注記を手動で追加できます。転送履歴の注記ダイアログで、転送履歴ビュー エントリに追加する注記を入力します。

パラメータ列を除くすべての列をASC/DSC順序で並べ替えることができます。列を並べ替えるには、マウス ボタンを左クリックします。これは単一列の並べ替え専用です。

列は、列を選択し、新規場所にドラッグすることによって移動可能です。列はサイズを変更することも可能です。行は番号付きの行ヘッダーをクリックして選択できます。

フィルタが有効になっている場合、新規に実行されたデータ転送の結果が、フィルタ条件を満たしているかどうかに関係なく、一番上の行に挿入されます。並べ替えが有効な場合、新規エントリは並べ替え順序に従って挿入されます。

サマリー列には、ソース データベース、テーブル名などのデータ転送の簡単な要約が含まれています。ジョブ出力は、履歴エントリを選択し、ツールバーのジョブ出力の表示をクリックすると表示できます。失敗したデータ転送は、ステータス列で赤いテキストとして表示されます。

ツールバー アクション

アイコン オプション 説明
名前の編集 クリックして、転送履歴エントリの名前を編集します。
注記の編集 クリックして、転送履歴エントリの注記フィールドを編集します。
選択した行の削除 クリックして、選択した行をビューおよび転送履歴データベースから削除します。
表示のフィルタ クリックして、表示をフィルタするダイアログを開きます。
フィルタのクリア クリックして、フィルタをクリアし、転送履歴表示を更新します。
ジョブ出力の表示 クリックして、ジョブ出力を表示します。

ツールバー メニュー

アイコン オプション 説明
名前の編集 クリックして、転送履歴エントリの名前を編集します。
注記の編集 クリックして、転送履歴エントリの注記を編集します。
選択した行の削除 クリックして、選択した行をビューおよび転送履歴データベースから削除します。
  すべての転送履歴の削除 クリックして、転送履歴データベースのすべてのエントリを削除します。
フィルタ クリックして、表示をフィルタするダイアログを開きます。
フィルタのクリア クリックして、現在のフィルタを表示から削除します。
再実行 クリックして、転送履歴リストの選択したデータ転送ジョブを実行します。
転送ジョブ出力の表示 クリックして、選択したデータ転送ジョブのジョブ出力を表示します。

列のヘッダー

列名 説明
名前 転送ジョブの名前。
タイムスタンプ 転送イベントの時刻。形式はyyyy-mm-dd hh:mm:ss.mmです。
ソース 転送のデータ ソースであったデータベースのプロファイル名。
宛先 データが転送されたデータベースのプロファイル名。
ステータス 転送イベントのステータス。
継続時間 ソースと宛先間のデータ転送に必要な時間の長さ。形式はhh:mm:ss.mmです。
転送された行 転送されたテーブル行数。
注記 転送イベントに関するテキスト注記。
サマリー 転送ソース パスおよび宛先パスを説明する技術的な要約。

列見出しコンテキスト メニュー

列を非表示、表示、サイズ変更するには、列見出しを右クリックします。検索機能を使用して、列行のデータを見つけることもできます。
アイコン オプション 説明
列の非表示 現在の列を非表示にします。
すべての列の表示 すべての列を表示します。
列の自動サイズ変更 現在の列のサイズを変更します。
検索 列の行の値を検索するための検索ダイアログを表示します。 転送履歴ビューで値を検索します。