16.20 - データベース キャッシュ - Teradata Studio

Teradata® Studio™ Express ユーザー ガイド

prodname
Teradata Studio
vrm_release
16.20
created_date
2019年3月
category
ユーザー ガイド
featnum
B035-2042-039K-JPN
キャッシュする特定のデータベースまたはユーザーを指定するには、データベース キャッシュ オプションを使用します。 データベース キャッシュ ファイルは、テーブル、列、制約、インデックス、マクロ、パラメータ、ストアド プロシージャ、ユーザー定義関数、ユーザー定義型、ビューなど、データベースに関する情報を記述するメタデータを格納するために作成されます。このメタデータは、データ ソース エクスプローラおよび転送ビュービューに表示されます。
データベース キャッシュ オプションは、接続プロファイルと関連付けられています。接続プロファイルを削除すると、データベース キャッシュリストおよび作成されたデータベース キャッシュ ファイルもすべて削除されます。

データベース キャッシュの継承

データベースを階層形式で表示するようにデータ ソース エクスプローラのロード オプションが設定されている場合、子データベースと子ユーザー オブジェクトが親データベースまたは親ユーザー オブジェクト下にネストされます。キャッシュされるデータベースまたはユーザー オブジェクトを選択すると、すべての子データベースと子ユーザー オブジェクトもキャッシュされます。データ ソース エクスプローラのロード オプションを変更すると、データベース キャッシュは削除され、新規選択を使用して再キャッシュされます。

進行状況モニター

最初にデータベースに接続し、データベース フォルダを開くと、データベース キャッシュ ファイルがバックグラウンド ジョブで作成されます。データベース キャッシュ ジョブの進捗を表示するには、
  • ウィンドウ > ビューの表示 > その他 > 一般 > 進行状況を選択します。
  • OKをクリックします。
Oxygenフレームワークを使用した進行状況モニターの動作変更の結果、初期設定では常にバックグラウンドで実行の設定がチェックされ、進行状況モニターは最小化されています。進行状況を表示するには、
  1. ウィンドウ > 設定を選択します。
  2. 一般を選択します。
  3. 常にバックグラウンドで実行チェック ボックスをオフにします。
  4. 適用して閉じるをクリックします。

キャッシュの更新について

キャッシュが作成されたら、更新をクリックして、データベース キャッシュ ファイルからキャッシュされたデータベースをロードします。キャッシュされたデータベースは、キャッシュ アイコンで識別されます。

新規データベース オブジェクトがデータベース キャッシュからロードされている間にデータベースが変更さた場合、データベース キャッシュを更新するまで変更されたオブジェクトはデータ ソース エクスプローラに表示されません。特定のデータベースのデータベースキャッシュを更新するには、キャッシュされたデータベースを右クリックしてを選択します。このアクションは、データベース キャッシュ ファイルを削除し、新規バックグラウンド ジョブを起動して、新規データベース キャッシュ ファイルを作成し、データベースのリストを更新します。

TeradataJDBC接続プロパティ ダイアログでデータベース キャッシュ ファイルを削除してデータベース キャッシュを更新することもできます。データ ソース エクスプローラはデータベー スオブジェクトへの変更を表示します。データベース フォルダを更新すると、データベース キャッシュ ファイルからデータベースがロードされます。

キャッシュ ジョブの終了

データベース キャッシュ ジョブを終了すると、データベース メタデータからロードするデータベース キャッシュ ファイルおよびデータベースが削除されます。データベース キャッシュ ジョブを再起動するには、接続プロファイルを切断してから再接続し、データベース フォルダをクリックして開き、データベース キャッシュ ファイルを作成する必要があります。