17.00 - Migrating Existing Database Applications - IBM CICS Interface for Teradata

IBM CICS Interface for Teradata® Reference

prodname
IBM CICS Interface for Teradata
vrm_release
17.00
created_date
June 2020
category
Programming Reference
featnum
B035-2448-220K

If you have existing CICS applications accessing the database (at the version 1, pre-5.0 level) that you wish to execute under CICS/ESA, they must first be re-link-edited with the 5.0 link-edit stub.

Once relinked, these applications execute against the 5.0 release of the Teradata CICS Attachment Facility runtime code under any supported CICS release.

When migrating Preprocessor2 or CLIv2 applications that were linked with the pre-5.0 version of the link-edit stub, observe the following:

IF the application is written with. . . AND it is invoked under . . . THEN . . .
AMODE31 CICS/ESA 3.2 or above running the 5.0 version of the Teradata CICS Attachment Facility it abends with code STUB.
any version of CICS prior to CICS/ESA 3.2 it runs without error.
AMODE24 CICS/ESA 3.2 or above running the 5.0 version of the Teradata CICS Attachment Facility the result is unpredictable, but may include any of the following codes:
  • ASRA
  • AICA
  • STUB
any version of CICS prior to CICS/ESA 3.2 it runs without error.