16.20 - DSA Package Names - Data Stream Utility

Teradata® DSA - DSU Installation, Configuration, and Upgrade Guide

prodname
BAR
Data Stream Architecture
Data Stream Utility
vrm_release
16.20
created_date
September 2019
category
Configuration
Installation
featnum
B035-3153-127K

The following table lists the software packages and dependencies for each DSA component, plus a summary of component functionality.

DSC, DSAPostAMQ, ClientHandler, BARCmdline, and BARPortlets must be on the same version.
Software Package Name Dependencies Description
DSC-version [DSA 16.20.24.xx and later] Teradata-Jdk8

[DSA 16.20.23.xx and earlier] Teradata-Jdk7

The Data Stream Controller (DSC) controls BAR operations and enables communication between DSMain, the BAR portlets, and the DSA Network Client (ClientHandler).

All installations require Version 7. DSA 16.20.24 and later versions also require Version 8.

ClientHandler-version None ClientHandler is the base package for both DSU and DSE, and handles communication to the targets of backup and restore jobs that are remote from the NewSQL Engine / Teradata Database nodes. ClientHandler is also known as DSA Network Client or DSA NC.
BARCmdline-version None The DSA command-line interface provides an alternative to the BAR portlets, allowing job creation, launch, monitoring, and scheduling and providing commands to configure DSA.
BARPortlets-version Viewpoint software The BAR Setup portlet allows you to designate the hardware and software to use when backing up your Teradata system.

The BAR Operations portlet allows you to create, manage, and submit jobs.

AXMDDBoost-version ClientHandler AXMDDBoost is an access module you can install for EMC Data Domain targets.
AXMS3-version ClientHandler AXMS3 is an access module you can install for Amazon S3 targets.
AXMAzure-version ClientHandler AXMAzure is an access module you can install for Microsoft Azure targets.
DSAPostDeployer-version None Contains a script, modify_dsc_name.sh, and a jar file, dsa-post-deployer.jar. These are used to update the DSC name in the repository.
DSAPostAMQ-version [DSA 16.20.51 and later] tdactivemq 5.15.9

[DSA 16.20.50 and earlier] tdactivmq 5.13.1

Contains one script, tdactivemq_wrapper.py. This required script configures tdactivemq for use.
Important: DSC, DSAPostAMQ, ClientHandler, BARCmdline, and BARPortlets must be on the same version.

Version numbers for DSA software packages are displayed in a xx.xx.xx.xx-xxxxxx format, for example, DSC-16.20.00.00-431571.x8664.rpm.