16.20 - Recovering from Failure during the DSC Repository Upgrade - Data Stream Utility

Teradata® DSA - DSU Installation, Configuration, and Upgrade Guide

prodname
BAR
Data Stream Architecture
Data Stream Utility
vrm_release
16.20
created_date
September 2019
category
Configuration
Installation
featnum
B035-3153-127K
  1. Drop the BAR and BARBACKUP databases, by running the following commands in BTEQ: delete database BAR; drop database BAR; delete database BARBACKUP; drop database BARBACKUP;
  2. Check if DSC is already installed and remove if necessary.
    1. Check if the DSC is installed: rpm -qa DSC
    2. If the DSC is installed, remove the package: rpm -e nameofpackage
  3. Re-install the previous version. The repository is corrupt so it must be recovered to the previous version before attempting the upgrade again.
  4. From the DSA installation directory, import the configuration file you exported before the upgrade (step 2 of Backing Up DSC Repository and Configuration Before Upgrading). dsc import_repository_backup_config -f export_repository_backup_config.xml
  5. If SSL is not enabled for this system, restart the ClientHandler.
  6. If SSL is enabled for this system, perform the following in the BAR Setup portlet:
    1. From the CATEGORIES list, click Systems and Nodes and select the repository.
    2. Select the Enable SSL over JMS Communication checkbox and enter the TrustStore password.
    3. Click Apply and enter the credentials when prompted.
    4. Restart DSMain on the DSC repository system as indicated in the warning message.
    5. From the CATEGORIES list, click Media Servers, select the media server used for repository backup, and click Apply. This activates the media server in the background.
  7. Recover saveset information: dsc recover_backup_metadata -n repository_target_group
  8. Run a repository restore job using the BAR Setup portlet or the run_repository_job command. dsc run_repository_job -t restore
  9. Perform a tpareset to the DSC repository database.
  10. [Optional] Re-attempt the upgrade.