16.20 - DSA 实用程序设置 - Teradata Data Mover

Teradata® Data Mover 用户指南

Product
Teradata Data Mover
Release Number
16.20
Published
2021 年 11 月
Content Type
用户指南
Publication ID
B035-4101-107K-CHS
Language
中文 (简体)

Data Mover 支持并捆绑了用于在 Teradata 系统之间复制数据库和表的 Teradata Data Stream Architecture (DSA)。

以下组件是 DSA 功能的一部分。务必注意在使用 Data Mover DSA 实用程序之前需要安装和配置的组件:
组件 说明
数据流控制器 (DSC) DSC 控制所有备份和恢复 (BAR) 操作,随 Data Mover 守护程序捆绑和安装。您可以将 Data Mover DSA 实用程序与外部 DSC 或捆绑的 DSC 结合使用。有关详细信息,请参阅《Teradata® Data Mover 安装、配置和升级指南(适用于客户)》。
DSMAIN DSMAIN 在 Teradata Database 节点上运行,用于从 DSC 接收作业计划。您必须配置并启用 DSMAIN,它才能与 Data Mover DSC 通信以运行作业。DSMAIN 安装在 Teradata Database 版本 14.10 和更高版本上。有关在源系统和目标系统上进行配置以启用 Data Mover DSC 的信息,请参阅《Teradata® Data Mover 安装、配置和升级指南(适用于客户)》。
DSA 网络客户端 也称为 BAR 网络客户端(或者 BAR NC 或 ClientHandler)。DSA 网络客户端使用共享网络数据管道将数据从源 DSMAIN 复制到目标 DSMAIN。安装并配置了 DSA 网络客户端软件的服务器也称为媒体服务器。在使用 Data Mover DSA 实用程序时,建议选择源或目标 Teradata Database 作为媒体服务器以获得最佳性能。有关安装和配置 DSA 网络客户端的信息,请参阅《Teradata® Data Mover 安装、配置和升级指南(适用于客户)》。
DSA 命令行界面 (CLI) DSA 命令行接口提供用于定义 DSA 配置的命令,随 Data Mover 守护程序打包和安装。

规则和限制

  • Data Mover DSA 实用程序需要额外配置后才能使用。
  • 如果您的环境中存在为备份和还原应用程序指定的外部 DSA,并且您希望使用 Data Mover DSA 实用程序,则必须升级现有的外部 DSA 组件(包括 DSC 和 BAR NC),确保它们与 Data Mover DSA 实用程序的版本一致。
  • 如果源或目标系统中的 Teradata Database 版本低于 16.00,并且使用 Data Mover DSA 实用程序来复制数据,则存在以下限制:
    • 同一时间数据库只能与一个 DSC 环境协同工作。下表显示了两个 DSC 使用同一个版本低于 16.00 的 Teradata Database 系统时可能出现的错误:
      方案 结果
      系统上已存在 DSA BAR 环境 安装的 Data Mover 环境捆绑了 DSC,并且运行以下作业:
      1. 来自系统 A 的 BAR 备份作业。
      2. 用于将数据从系统 A 复制到系统 B 的 Data Mover DSA 作业。
      如果系统 A 使用的数据库版本低于 16.00,则 BAR 作业不再有效。在 DSC 环境之间切换时,必须重新配置系统 A 上的 DSMAIN。
      存在两个 Data Mover 环境:测试和生产 两个 Data Mover 环境均具有捆绑的 DSC,并且运行以下作业:
      1. Data Mover 测试环境中用于将数据从系统 A 复制到系统 B 的 Data Mover DSA 作业。
      2. Data Mover 生产环境中用于将数据从系统 B 复制到系统 C 的 Data Mover DSA 作业。
      如果系统 B 使用的数据库版本低于 16.00,则 Data Mover 测试环境中的作业不再有效。这种情况下,在 DSC 环境之间切换时,必须重新配置系统 B 上的 DSMAIN。
      存在支持自动故障转移的 Data Mover 环境,其中包括活动和备用 Data Mover 守护程序 为活动和备用 Data Mover 守护程序均配置了捆绑的 DSC,并且在运行以下作业后发生故障转移:
      1. 活动 Data Mover 守护程序上用于将数据从系统 A 复制到系统 B 的 Data Mover DSA 作业。
      如果任一数据库使用的版本低于 16.00,则新升级的守护程序上的作业将失败。在 16.00 之前版本的数据库上发生故障转移时,必须重新配置 DSMAIN。
    • 在作业定义中未指定 force_utility 时,不会为源或目标数据库自动选择 DSA。对于了解这些限制并希望使用 Data Mover DSA 实用程序将数据复制到更低版本数据库的高级用户,必须将 DSA 指定为 force_utility