2.10 - Updating Hive Classpath after Upgrading the Hive Connector - Teradata QueryGrid

Teradata® QueryGrid™ Installation and User Guide

prodname
Teradata QueryGrid
vrm_release
2.10
created_date
September 2019
category
Administration
Configuration
Installation
User Guide
featnum
B035-5991-099K
When the Hive connector .jar files are located on the Hive classpath, the old .jar files on the Hive classpath must be removed and replaced by new ones when upgrading the Hive connector. In particular, the following files must be replaced:
  • hive-qginitiator-version.jar (for 02.04 and earlier)
  • hive-qgremote-version.jar (for 02.04 and earlier)
  • hive-loaderfactory-version.jar (for 02.05 and later)
Failure to replace the old .jar files can render the upgraded Hive connector unusable.