Teradata Database メッセージ 5260 - 17.00 - 5260 - Teradata Database

Teradata Vantage™ - Database Messages

prodname
Advanced SQL Engine
Teradata Database
vrm_release
17.00
created_date
2020年6月
category
プログラミング リファレンス
featnum
B035-1096-170K-JPN
メッセージ
Un(Compress) failed. Required hardware compression support package teradata-expressdx... and/or teradata-libeLZS... is not installed.
説明
選択した圧縮アルゴリズム (ELZS_HまたはELZS_S) には、パッケージ teradata-expressdx.. のハードウェア圧縮サポート ライブラリが必要です。および/またはテラデータ libeLZS...、システムにインストールされていません。 サポートライブラリがインストールされていない限り、このエラーは持続し、選択したアルゴリズムを使用してデータを圧縮することはできず、上記のライブラリ/パッケージを必要とする以前に圧縮されたデータを、それ以降の処理のために圧縮解除/アクセスすることはできません。
生成もと
ファイル・システム
対象ユーザー
TVI調査
注意
構成に問題がある
対処法
次のいずれかの場合は、ハードウェア圧縮サポート ライブラリが含まれているパッケージをインストールします。1) システムは、DBS制御GDOで指定されているELZS_H圧縮またはELZS_S圧縮を使用して続行する必要がある。2) DBS制御GDOで現在指定されているアルゴリズムに関係なく、ELZS_HまたはELZS_Sを使用して以前に圧縮された既存データがあるため、選択されたアルゴリズムを使用して圧縮解除/アクセスおよび再圧縮するか、または非圧縮のままにする必要がある。そうでなければ、ELZS_HまたはELZS_Sを使用して以前に圧縮されたデータがシステムに存在しない場合は、別の圧縮アルゴリズムを指定します。Exarハードウェア圧縮カードがあるプラットフォーム(2690、2700、2750)では、次のパッケージをインストールします。1) teradata-expressdxパッケージ、2) teradata-libeLZSパッケージ。それ以外のプラットフォームでは、teradata-libeLZSパッケージをインストールします。