17.00 - Required Software Dependencies for Teradata PT - Parallel Transporter

Teradata® Parallel Transporter Application Programming Interface Programmer Guide

prodname
Parallel Transporter
vrm_release
17.00
created_date
June 2020
category
Programming Reference
featnum
B035-2516-220K

The following table lists the Teradata Tools and Utilities 17.00 version of the following products that are required to run the code samples for Teradata PT.

Product Package Name
Teradata International Components for Unicode (Teradata ICU) tdicu
Teradata Generic Security Services (TeraGSS) TeraGSS
Teradata Call Level Interface Version 2 (Teradata CLIv2) cliv2
Teradata PT Base tptbase
Teradata PT Stream Operator (if used) tptstreamop

It is preferred that the products listed in the table be installed in the order listed; however, each product states its prerequisites at install time.

For Teradata Tools and Utilities 17.00 products, the full version number for packages is 17.00.00.xx. The last two numbers in the version string denote the e-fix version with the latest release having the greatest e-fix number. Before using an e-fix version of a product, review the corresponding e-fix ReadMe file for fix information and for documentation on any resulting usage changes.

For the Teradata PT default installation directory and the environment variables that need to be set before using Teradata PT, see appropriate Teradata Tools and Utilities installation guides at https://docs.teradata.com/.

See Platform Compilers for the supported versions and releases of the platform compilers.