View Menu Commands and Toolbar

Teradata Visual Explain User Guide

brand
Teradata Tools and Utilities
prodname
Visual Explain
vrm_release
16.10
16.20
category
User Guide
featnum
B035-2504-086K

Use the View menu and toolbar to work with the information in the Teradata Visual Explain window. View database configurations, connectors, indexes, object definitions, statistics, and summary information related to the displayed execution plan. Commands on this menu also set the display font, set the zoom level, and provide a view pad (an easy way to navigate large plans).

View Menu Commands, Submenus, and Toolbar Buttons 
Command Submenu Button Description
Toolbars
  Standard None Toggle the Standard toolbar on or off.

For more information, see File Menu Commands and Standard Toolbar.

  View None Toggle the View toolbar on or off.
  Plans None Toggle the Plans toolbar on or off.

For more information, see Plans Menu Commands and Toolbar.

  Tools None Toggle the Tools toolbar on or off.

For more information, see Tools Menu Commands and Toolbar.

Status Bar None None Toggle the status bar on or off.
Spool Space Utilization None View the current and maximum spool space of the current user.
Compressed None View the data-flow-oriented layout of the execution plan.
The command is only available when a plan is open.
Expanded None View the control-flow-oriented layout of the execution plan.
This command is only available when a plan is open.
Teradata Database Configuration None View the configuration of the database the execution plan was captured on.
This command is only available when a plan is open.
Summary Information None Toggle the Summary Information window open or closed. The window displays information about the execution plan.
This command is only available when a plan is open.
Show Connectors None Display additional connectors (made up of dashed lines) depicting spool reuse.
View Pad None Show an overall view of plans that span multiple horizontal and vertical pages.
This command is only available when a plan is open.
Show Demographics None View the demographics of the tables used in the plan.
This command is only available when a plan is open.
Object Use Count None None View a report of all objects used in the displayed plan.
This command is only available when a plan is open.
Current vs. Captured
This command and related submenus are only available when a plan is open.
  Indexes View the indexes on objects used in the execution plan.
  Object Definitions View the definitions of the database objects used in the execution plan.
  Statistics View statistics for the tables used in the execution plan.
Actual vs. Estimated
This command and related submenus are only available when a plan is open.
  Cardinality View the actual and estimated cardinality of each spool in the execution plan.
  Cost View the actual and estimated cost of each step in the execution plan.
Set Font None Display the Font dialog box to change the display font.
Zoom None Set the size of the display.
None None Toggle audible notification on or off.
None None Go to the previous spool reference.
None None Go to the next spool reference.
The View toolbar includes toolbar buttons (not described in the table) for some of the more commonly used menu commands. See Window Menu Commands and View Toolbar for a description of these buttons.