RESULTS Tab

Teradata Warehouse Miner User Guide - Volume 1Introduction and Profiling

brand
Software
prodname
Teradata Warehouse Miner
vrm_release
5.4.4
category
User Guide
featnum
B035-2300-077K
The RESULTS tab is empty until the analysis is executed. Each RESULTS tab contains one or more of the following tabs under the RESULTS tab which changes the results to browse. Subsequent sections describe the results pertinent to each analysis.
  • Reports — The Reports tab includes all the messages generated by the analysis as well as report tables generated by the analysis. Typically, these are statistical reports generated by the analytical algorithms or scoring functions.
  • SQL — The SQL tab changes the form to show any SQL generated by the analysis. By default, all SQL statements are shown; however, statements can be shown individually through the Show Statement pull-down list.
    The following options are provided, both via buttons and right-click menu options.
    • The Copy function copies all the highlighted SQL text to the Clipboard.
    • The Find function provides an option to search for whole words and an option to search for a case specific match, along with an option to start the search from the beginning or from the current cursor position.
    • The Select All function selects (highlights) the entire SQL text.
    • The Create SQL Node function places the entire SQL text into a new Free Form SQL analysis in the same project.
  • Data — The Data tab changes the form to show any data generated by the analysis. If tables are created, a Load button must be clicked to show the data generated within a data grid. Once this is done, or if a SELECT statement was requested, the data grid is displayed. Note that if the Maximum result rows to display field in Tools > Preferences > Limits is set to a value less than the rows in the result table, only the rows specified by the limit are shown. Scoring is a special case in which a sample of the number of rows specified by the limit is taken. If the analysis generated multiple tables, each can be viewed via the result table pull-down list.
    The following buttons provide options when viewing results data. These same options are also available as right-click menu options.
    • Edit — Clicking Edit provides a pop-up menu with the following options:
      • The Copy option copies all the highlighted SQL text to the Clipboard.
      • The Find option provides an option to search the current column only (i.e., the column that contains the currently selected cell), and an option to search for a case specific match, along with an option to start the search from the beginning or the current cursor position. If the specified text is found in a cell, that cell is selected. In order to further find the desired text within the selected cell, the View Cell function can be used.
      • The Select All option selects (highlights) the entire SQL text.
      • The View Cell option copies the text within a cell in the results data grid into a text viewer for easier viewing. The text viewer is resizable and provides a “word wrap” option, as well as the right-click menu options Copy, Find and Select All. The View Cell option can also be invoked by double-clicking on a cell. (The View Cell option is useful when the cell contains more data than can be easily viewed or when it contains embedded line feed characters, such as with the results of a SHOW TABLE command). Note that the View Cell window can be kept open while different cells are selected in succession and their contents viewed in the open window.
      • The Show Table/View option is available only when the analysis has created an output table or view. It executes an SQL SHOW TABLE or SHOW VIEW command against the output table or view and displays it in a text viewer. As with the View Cell window, the text viewer is resizable and provides a “word wrap” option, as well as the right-click menu options Copy, Find and Select All.
    • Format — The data grid supports both numeric and date formatting options for each column in the data set. Two values are used to format numeric data—the ‘0’ and the ‘#’ characters.
      • The ‘0’ (zero) character forces the formatting for a number regardless of the precision of the number. For instance, the number ‘1’ with the format ‘0.00’ would become ‘1.00’ and the number ‘1.2345’ would become ‘1.23’.
      • The ‘#’ (pound) character will display a digit only if it exists. For example, the number ‘1’ with the format ‘#.##’ would become ‘1.’ and the number ‘1.2345’ would become ‘1.23’. An exception to this is that with scientific notation, leading '#' characters behave like '0' characters and don't work as expected for decimal or exponent places.
      Date and timestamp formatting use the characters ‘y, M, d’ for date formats, and ‘H, h, m, s’ for time formats.
      • The year format character ‘y’ may appear as two or four characters.
      • The ‘M’ character for month may appear as one, two, three or four characters, giving a one/two digit, two digit, three character abbreviated or full name version of the month, respectively.
      • The ‘d’ character for day may appear as one, two, three or four characters, giving a one/two digit, two digit, three character abbreviated or full name version of the day of the week, respectively.
      'H', 'h', 'm' and 's' characters may appear as one or two characters.
      • The 'H' character gives an hour value in a 24-hour format.
      • The 'h' provides an hour value in a 12-hour format.
      • The 'm' character represents minutes and the 's' character seconds.
      • Decimal seconds may be shown by following 's' or 'ss' with decimal places, as in 'ss.00'.
      The letters 'tt' after a timestamp format adds AM/PM as appropriate. Any separator may be used to separate the formatting, although the most popular for dates are the ‘/’ and ‘-‘ characters.

      The formatting of result columns of type Time is not provided.

      Several built-in formats are automatically included as Available Format Strings. These may vary depending on locale and the standard numeric and date formats for that locale. Custom formats may also be entered, which are automatically added to the Available Format Strings and retained as long as the Results window remains open. The following table lists the types of built-in formatting based on a U.S. English locale.

      Built-In Formatting
      Format String Column Type Description
      (None) All No formatting
      0 Numeric Integer format
      0.00 Numeric Decimal format with standard decimal places
      #,##0 Numeric Integer format with standard grouped digits
      #,##0.00 Numeric Decimal format with standard grouped digits and decimal places
      0% Numeric Integer percentage
      0.00% Numeric Decimal percentage with standard decimal places
      0.00E+00 Numeric Scientific notation with standard decimal places and one higher order digit
      ##0.00E+00 Numeric Scientific notation with standard decimal places and 3 higher order digits
      M/d/yyyy Date/Timestamp Brief date format
      M/d/yyyy h:mm tt Date/Timestamp Brief date and time format
      dddd, MMMM dd, yyyy Date/Timestamp Complete date format
      dddd, MMMM dd, yyyy h:mm:ss tt Date/Timestamp Complete date and time format
      yyyy'-'MM'-'dd'T'HH':'mm':'ss Date/Timestamp Date and time in a sortable format
      MMMM dd Date/Timestamp Month name and day
      MMMM, yyyy Date/Timestamp Month name and year

      Clicking Format displays the following dialog.

      Format Columns

      Highlight one or more columns to format, and either type in the desired format within the Selected Format String text box or select it from the Available Format Strings list to apply it to the selected columns. Click OK to accept all changes. Note that the first highlighted column in the list of columns determines the initial entry in the Selected Format String text box.

    • Sort — The data grid supports an N-Column sort. Clicking Sort displays the following dialog.
      Sort Columns

      Select the column(s) you wish to sort the data set by, either by dragging and dropping from Available Columns to Selected Columns, or highlighting the desired column(s) and clicking on the right arrow. Once the appropriate columns have been selected, use the up/down arrows to specify the order in which the data should be sorted, with the first column listed taking precedence. Double-clicking on any given column changes the sort mode from Asc(ending) to Desc(ending).

      The Sort Columns dialog may be resized by clicking on one of the edges or corners and moving the mouse while holding the button down.

    • Export — Clicking Export exports the data in the data grid to a new instance of a Microsoft Excel worksheet, which the user may then use to manipulate, print and/or save the data. If no rows are selected, all of the displayed rows are exported. If one or more rows are selected, only the selected rows are exported.

      If more than one Results table is available, an option is provided to export all of the tables at once rather than just the table being viewed. When this option is selected, all of the data available for all of the tables in the Results viewer is exported to a single worksheet, with blank rows separating the rows for each results table. (If this option is selected, any row selections in the table being viewed are ignored, taking all of the available rows).

      The Results viewer limits the number of rows available for each result table to the limit determined by the Tools > Preferences option Maximum result rows to display on the Limits tab, a value that is by default 1000 rows per result table. This value must be increased in order to export more data to Excel. Note, however, that Excel will not accept more than 65,536 rows or 256 columns in total, and will ignore rows and/or columns beyond these limits (after loading the rows or columns up to these limits).
  • Graphs — The Graphs tab displays any visualizations created by an analysis.
    • Drill Down — The graphs for the Descriptive Statistics functions Frequency, Histogram, Values, Statistics and Data Explorer additionally have graph drill down capabilities. Drill down queries can be saved with the analyses that create them, but are not retained when an analysis is exported to a file. Available graphs and their drill down capabilities, if any, are described in detail in the sections that describe results graphs for the analyses that provide them.
      Drill Down will not work properly when the table being analyzed is a volatile table created by a referenced analysis that doesn't create an output table or view.
      The following right-click menu options are available from the display of drill down data rows after drill down is performed. They can be used to copy data to Microsoft Excel or to the Clipboard. When copying data to the Clipboard, columns are delineated by tab characters.
      • Export to Excel - All Rows
      • Export to Excel - Selected Rows
      • Copy (to Clipboard) - All Rows
      • Copy (to Clipboard) - Selected Rows

      In addition, all Teradata Warehouse Miner graphs have the following properties that can be selected by right-clicking on the graph to bring up a menu of options:

    • Maximize — With the exception of the Decision Tree Browser graphical object, all Teradata Warehouse Miner graphs can be maximized to the full size of the screen. In order to maximize a graph, right-click on a graph and select the Maximize option.
    • Print — All graphs can be printed directly from the graph option menu by selecting the Print option. If this option is selected a similar print dialog is displayed.
    • Export — Graphs can be exported to the Microsoft Clipboard, saved to a file, or printed in a variety of formats and styles through the following dialog. The dialog dynamically displays appropriate choices based on the selected export format, as illustrated below.
      Graph Export

      This dialog is shown below:

      Exporting dialog

    • Export Format — In general, graph images can be saved to file or Clipboard using either MetaFile, BMP or JPG formats, and printed using the MetaFile format. All graph aspect ratios (width / height) need to remain between 0.333 and 10.0 to preserve image quality. Default image sizes reflect currently displayed graph dimensions.

      MetaFiles are images compressed using a Microsoft vector-based codec that allows images to be resized without distortion or loss of detail when the aspect ratio is maintained. The MetaFile ‘No Specific Size’ option creates images using the current graph aspect ratio (width / height). If the aspect ratio needs to be modified, then graph size dimensions can be specified, as well.

      MetaFiles can be printed either full-page or by specifying a size using millimeter, inches or points units of measure. When the Print option is selected, clicking Export displays an additional printer dialog so the target printer can be selected.

      Bitmaps and JPEG encoded images saved to file or Clipboard can be sized using Pixel dimensions.

    • MetaFile — Export the graph as a Microsoft Metafile.
    • BMP — Export the graph as a bitmap file.
    • JPG — Export the graph as a JPEG file.
    • Text/Data Only — Export the graph as text only. Only Histogram and Frequency graphs support the exporting of data and column labels to text files (and these only when not accessed from the Data Explorer thumbnail graphs). All data displayed in the flex grid (graph options tab) can be exported or just the selected rows. Exported text files store the data in list formats (with tab or comma delimiters) or alternately in table formats.
    • Export Destination
      • ClipBoard — Export the graph to the Microsoft Clipboard.
      • File — Export the graph to a file.
      • Printer — Export the graph to a system attached printer.
    • Graph Size — Specify the Graph Size of the Windows Metafile, in either:
      • No Specific Size — A resolution independent dimensioning of the graph image.
      • Millimeters — Specify the image size in millimeters.
      • Inches — Specify the image size in inches.
      • Points — Specify the image size in points.

      Or, specify the Graph Size of the BMP or JPEG, in:

    • Pixels — Specify the image size and aspect ratio in pixels.

      Or, specify how the text should be exported:

    • List
      • Tab — Export the data in the data grid in a tab delimited format.
      • Comma — Export the data in the data grid in a comma delimited format.
    • Table — Export the data in the data grid as a Table.
    • Data to Export
      • All Data — Export all the data in the data grid.
      • Selected Data — Export just the data currently selected in the data grid.

      Click on the Export button to perform the selected export operation, or Cancel to cancel the Save Graph and return to Teradata Warehouse Miner.

    • Zoom Out (All Data) — Often times graphing tremendous amounts of data require the graphs to have scroll bars. If this is not the desired visualization, and you want to see all the data within a single screen snapshot, the Zoom Out (All Data) option can be used. This will produce a compressed image that is guaranteed to be displayed without having to scroll.