Metadata Maintenance

Teradata Warehouse Miner User Guide - Volume 1Introduction and Profiling

brand
Software
prodname
Teradata Warehouse Miner
vrm_release
5.4.4
category
User Guide
featnum
B035-2300-077K

This option brings up the Metadata Maintenance dialog to maintain the projects and analyses stored in the current Metadata Database, as shown below.

Metadata Maintenance

  • Title — The title indicates the database containing the metadata tables with the metadata to be maintained.
  • Projects — When the Projects folder is highlighted in the view on the left, it causes a summary of projects contained in the metadata to be displayed in the view on the right, with the total number of projects and/or folders indicated in the header of this view. By highlighting one or more projects in the view on the right and selecting either the Properties, Add, Edit, or Archive button, the appropriate dialog, described below, is displayed with the selected projects shown in the initial view. Note that the Properties button is enabled only if a single project or folder is selected in the view on the right.
  • Analyses — When a project is highlighted underneath the Projects folder in the view on the left, the analyses contained in that project are summarized in the view on the right, with the total number of analyses in this project indicated in the header of this view, as shown below. The second column in this display indicates the sequence number of the analysis within the project.

    Note that a special category labeled (Analyses without a Project) may be displayed underneath the Analyses folder in the view on the left if there exist analyses which are not part of any project in the metadata. This should typically only be the case if there were projects deleted in a version of Teradata Warehouse Miner earlier than version 5.0 and these projects contained analyses. When highlighted, the analyses without a project will be summarized on the right.

    Metadata Maintenance: Analyses In A Project

  • Properties — When a single project or analysis is selected in the view on the left or right, the Properties button may be selected to display the Project Properties or Analysis Properties dialog, as described in Project Menu. Note, however, that when displayed inside Metadata Maintenance, the Description field may not be used to enter a description for the project or analysis, but only to view the current description. Also, within the Metadata Maintenance dialog, the display of a project or analysis description is limited to 512 characters, even though the length is not similarly limited when entered or viewed in the Properties dialog when accessed from the Project window.

    If the Parameters tab, the References tab, or the Display names of output tables… option is selected on the Properties display, the selected project or the project containing the selected analysis is loaded behind the scenes from metadata in order to determine the requested information. If this occurs, then the shading of referenced analyses is supported for that project if the analyses are displayed in the view on the right, but not otherwise.

  • Add — When a single project is selected in the view on the left, or when one or more projects or analyses are selected on the right, the Add button may be used to add the projects or analysis copies to the project workspace from metadata. In particular, when one or more analyses are selected, the Add button leads to a menu of choices to add copies of the analyses either to the current project or a new project, and with or without database object mapping (after the manner of the Import Wizard).
    Edit — The Edit button may be used to request the following options:
    • New Folder — One or more new folders may be added to the main projects folder on the left side, or to any folders previously added to the projects folder. When highlighted on the left, the folders and/or projects contained in a given folder are displayed on the right. When a folder on the right side is double-clicked, it expands to show the folders and/or projects it contains.
    • Rename — The Rename option is available only to rename folders underneath the main projects folder on the left side display. Such folders may also be renamed by clicking on the name to the right of the folder.
    • Delete — See Edit-Delete below.
    • Expand All — Expands all of the analyses and projects in the left pane of the Metadata Maintenance dialog.
    • Collapse All — Collapses all of the analyses and projects in the left pane of the Metadata Maintenance dialog.
  • Edit-Delete — The delete option is available to delete one or more projects or analyses displayed on the right side, or a single project or project folder selected on the left side. When a project folder is deleted, all of the projects or folders it contains are also deleted. Selecting Edit > Delete leads to the dialogs described below.
    • Deleting Projects — In the example below, options are checked to delete both the displayed projects and their analyses and any tables or views created by the analyses.
      Metadata Deletion

      These options may also be used to delete projects and analyses without tables or views, or to delete created tables and views without deleting projects and analyses.

      When Next is selected, the following screen is displayed.

      Metadata Deletion: Confirm Project Deletion

      If one or more items is selected in either the upper or lower view of this display (or both), the appropriate Preserve button or buttons will be enabled and may be used to remove items from the lists of items to delete, thus “preserving” them.

      If the Delete button is selected, the listed projects, tables and/or views are deleted, if possible. Projects are deleted from metadata, along with all of the analyses they contain. Tables and/or views are deleted from the database containing them (note that the names are displayed in the format database.table or database.view).

      If the Auto-Archive deleted items option is checked, the items are archived to the standard archive used by the Auto-Archive feature prior to deletion. The default value of the check box is determined by the user preference option for automatically archiving deleted items. For more information about the archive/restore feature and automatic archiving, see the Archive bullet below.

      After selecting Delete, each view changes to indicate a status and possible error message. The status for the lower view will indicate whether or not the table or view was DROPPED, NOT FOUND (the tables or views may never have been created or they may have subsequently been dropped), or whether an ERROR occurred, in which case the error message is also displayed. Note that the columns in these displays may be resized by dragging the vertical bars in the column header with the mouse. To exit this final display, click Finish.

    • Deleting Analyses — When one or more analyses is selected on the Metadata Maintenance dialog and the Delete… button is selected, the following dialog appears.
      Metadata Deletion: Analysis Deletion Options

      If Next is clicked, a Confirm Analysis Deletion dialog, similar to the Confirm Project Deletion dialog shown previously, appears.

      Note that in the Analysis Deletion Options dialog above, there is an indented check box giving the option to delete any analyses that reference these analyses. This includes analyses that reference these analyses for input or that reference a matrix or model created by these analyses. If this option is checked, and such referencing analyses exist in the containing project, the referencing analyses will be included on the Confirm Analysis Deletion dialog. This option is available, however, only if the analyses to delete are all contained in the same project.

  • Archive — The Archive/Restore features utilize the Export and Import functions, respectively, along with an Archive Record File and logic to control the allocation and naming of multiple export files. These features can be useful in moving metadata to another system or database, recovering from the loss of metadata tables or recovering from the loss of an individual project, analysis or attachment. An automatic archive feature is also available to request the archiving of a project, analysis or attachment whenever one is deleted, or by request when a project is saved.

    A preference option controls archiving upon deletion, and archiving when saving is achieved with the Save <project> and Archive menu option available on the File menu and on the Project Area menu).

    When archiving projects, the user names and chooses a location for the archive record file, and selects the number of projects to be written to each export file (from 1 to 25). If one project is written to each export file, an option is provided to use the project names to name the export files. Otherwise, the archive record F\file name is used with the addition of an incrementing integer value.

    When restoring projects, the user may select the individual projects to be restored using the Import function. Options are provided so that projects may be restored with or without using the Import function’s database mapping screen. The default is to use database mapping.

    The Archive button leads to a menu with the following options:

  • Export to a single file — This option leads to the standard Export function as described in Export Wizard along with other File menu options. Note that when a project is selected in the view on the left, a single project is exported. When one or more projects are selected in the view on the right, one or more projects are exported. When a single analysis is selected in the view on the right, the project containing it is exported with only that analysis selected on the Export form, along with any analyses it refers to or is dependent on.
  • Archive to one or more files — Options are provided for the number of projects per export file and use project names for export file names (available only when the number of projects per export file is set to 1). Clicking Archive leads to a dialog to locate and name the archive record file, after which warning messages may be given to indicate that the file already exists and/or that export files about to be created already exist. The exports are then performed, displaying the status of each in the File column of the display. In particular messages are given indicating that a particular project is loading, has loaded or is now contained in the indicated file.
    Projects must first be loaded into memory, not the project workspace, before the exports can be performed.

    After the operation is complete, click View Record to open the actual archive record file for inspection, but the contents should not be altered. Viewing the record file should not be necessary but might be useful to more easily view error messages if any should be present.

  • Restore projects from archive — Selection of this option leads to a dialog to locate the desired archive record file. After a file is selected, the Restore Projects form appears, showing the archived projects and the files that contain them. The projects to be restored may then be selected manually or by clicking Select All near the bottom of the form.

    Clicking Restore brings up the Import Wizard, provided that the option to Import projects with database mapping is selected. If the option to Save projects directly to metadata is selected, however, a warning message is given to use caution with this option. Note that if a project is selected to be restored, all projects with the same name in the archive file that contains it will also be restored.

    Other buttons are provided, including an Open button for accessing another archive record file and a Delete button for deleting export files listed in the archive record file. Note that if the Delete button is selected, all of the projects for a selected file are selected to indicate that part of a file may not be deleted. Also, if all the files in an archive are selected for deletion, the archive record file is also deleted.

  • Restore auto-archived projects — The form appears when this option is selected is almost the same as that displayed when the Restore projects from archive option is selected. One difference is that the automatic-archive record file AutoArchive.txt is automatically located in the application file storage area and opened (if it exists), and thus there is no Open button. Also, additional columns are displayed, notably Item and Archive Date. The Item column indicates an analysis or attachment name if an individual item was archived automatically, or otherwise it is blank if an entire project was archived.
    The standard archive always works at the project level; it is only the automatic archive that will archive an individual analysis or attachment, as it may do when an analysis or attachment is deleted.
  • Delete all auto-archive files — This option removes the automatic-archive record file and all of the archive files it lists. In order to delete a subset of automatic-archive export files, click Delete on the Restore auto-archived projects form instead.
  • Set auto-archive options — This option is provided for convenience as an alternate way to access the Archive tab on the Preferences dialog, normally accessed from the Tools menu. The Archive tab contains an option to Automatically archive deleted projects, analyses and attachments.