Select Columns From...

Teradata Warehouse Miner User Guide - Volume 1Introduction and Profiling

brand
Software
prodname
Teradata Warehouse Miner
vrm_release
5.4.4
category
User Guide
featnum
B035-2300-077K

Column Selection Methods

  • The arrow buttons on the Analysis Input screen can be used to select or de-select columns displayed on the left into or out of one or more tree-structured views on the right.
  • Columns may be selected or de-selected by dragging them from the available columns view to a selected columns view, or back again.

    This is done by first highlighting one or more columns with left-mouse clicks, holding down the control or shift key to highlight multiple columns, and then holding down the left-mouse button while the mouse is dragged to the desired window and dropped by releasing the left-mouse button.

  • Columns can be selected individually (but not de-selected) by double-clicking on them to select them into the currently highlighted tree-structure view.

Note that most data selectors have a specialized selection mechanism specified by the “…” icon. This is analysis dependent and is a shortcut for data selection. When the icon is clicked, one or more tooltips are displayed, one of which can be chosen for data selection. For example, the specialized selection mechanism for the Data Explorer is “Select All Columns.” In this case, all columns are automatically moved from the Available to Selected lists. For Statistics, this mechanism is “Select all Numeric Columns.”

Tool-Tip Information

Tool-tip information is available about columns in the Available Columns and Selected Columns panels by holding the mouse pointer over a particular column name. The displayed fields include the following. Data Type, Character Set and Comparison are not displayed for columns from a referenced analysis.
  • Name - the name of the column
  • Type - a category (Numeric, Character, Date, Time, Timestamp, BigInteger, BigDecimal, Unknown and NotSupported) based on the actual data type and determining the color of the icon used for the column in list and tree views
  • Analytic Type - continuous or categorical (based on data type only, not use)
  • Data Type - the actual Teradata data type
  • Character Set - Latin, Unicode etc. (only if Character type)
  • Comparison - Case Specific or Not Case Specific (only if Character type)

Right-Click Menu Options - Available Columns

In the Available Columns panel on the left side of the input screen, the user can right-click and receive menu options as described below. These options work together with the Preferences set from the Tools menu. The Primary Index and Sort Order options may be used to temporarily override the default settings in Preferences.
  • Clipboard
    • Copy — Copies names of selected columns to the Clipboard.
    • Paste — (Not available for Available Columns)
    • Select — Selects (highlights) columns with matching names on the Clipboard.
    • Primary Index
      • In Bold — Displays primary index columns in bold font.
      • Normal — Displays primary index columns in normal font.
    • Sort Order
      • Alphabetical — Displays column names in alphabetical order.
      • Table Order — Displays column names in table order.
    • Show Table/View — This option displays the results of a SHOW TABLE or SHOW VIEW SQL command for the currently selected table or view. For a table, various table options such as FALLBACK are displayed, along with column names and types and a primary index clause, if any. For a view, the statement that was used to create the view is displayed. The dialog used to display the results is resizable and contains a Word Wrap option.

Right-Click Menu Options - Selected Columns

In the Selected Columns panel on the right side of the input screen, the user can right-click and receive menu options as described below. These options work together with the Preferences set from the Tools menu. In particular, the option to Enable multi-column tree view selection must be set in order for Clipboard Copy and Select options to work with Selected Columns.
  • Clipboard
    • Copy — Copies names of selected columns to the Clipboard.
    • Paste — Takes the list of columns on the Clipboard, if any, and if they occur in the Available Columns list, copies them into the Selected Columns list.
    • Select — Selects (highlights) columns with matching names on the Clipboard.
  • Switch Input To — This option applies when a database, table or column is highlighted on the right side of the input screen.

    When this option is selected, the database, table and/or column selectors on the left side of the input screen are adjusted to match the highlighted database, table, analysis or column on the right side of the screen.