Project Menu

Teradata Warehouse Miner User Guide - Volume 1Introduction and Profiling

brand
Software
prodname
Teradata Warehouse Miner
vrm_release
5.4.4
category
User Guide
featnum
B035-2300-077K

The following options are available from the Project (Alt-P) Menu:

  • Run <Analysis > F5 — Run the currently selected analysis within the project window. Alternately, the function F5 key executes a selected analysis as well. Before an analysis is executed, each analysis that it may refer to as the source of its input is automatically executed first. Since a referenced analysis may refer to other analyses as well, executing an individual analysis may result in the execution of a series of analyses.
  • Run <Project > F5 — Run the currently selected project within the project window. Alternately, the function F5 key executes a selected project as well. The analyses in the project are executed in order, one by one, except that analyses referenced for input are always executed before the analysis that refers to them.
  • Run To End <Analysis > F6 — Run the currently selected analysis within the project window followed by each of the subsequent analyses until the end of the project. Alternately, the function F6 key executes a selected analysis and subsequent analyses as well.
    Execution order may be affected when an analysis refers to another analysis in the project for its input, in which case the referenced analysis is always executed before the analysis that refers to it.
  • Run Stand-Alone <Analysis > F7 — Run the currently selected analysis within the project window without executing any analyses that it may reference for input. Alternately, the function F7 key executes a selected analysis as well.

    This option may result in an error if an analysis referenced for input has not created the required input table or if a created volatile table is no longer available.

    This option may be ignored in the Teradata Profiler product.
  • Skip during Project Execution — This option can be used to skip the execution of an individual analysis when the project that contains it is executed, whether in whole or in part when the Run to End option is used. It does not, however, skip the execution of an analysis that is executed by itself or as the result of being referenced by another analysis that is being executed by itself. The option works by toggling a flag that is saved with the analysis and is honored both in subsequent interactive and batch executions.

    Skipping the execution of an analysis during project execution may be useful in many instances. For example, the option can be used to avoid rebuilding a matrix every time an algorithm that uses it is executed to build a model, or similarly to avoid rebuilding a model every time an analysis that scores it is executed. Similarly, it can be used to avoid executing a chain of analyses an extra time when they are being refreshed or published with the Refresh or Publish analysis, respectively.

  • Stop <Analysis/Project> — Stop the currently executing analysis or project.
  • Add New Analysis… — Add a new analysis to the project.
  • Add Existing Analysis … — Add copies of one or more existing analyses to the currently selected project. For more information, see Adding Analyses to a Project.
  • Add Attachment … — Create an attachment folder within the specified project and copy any valid windows object into it, such as a document file.
  • Delete <Analysis/Project> — Delete the currently selected analysis or project within the project window. Before the analysis or project is deleted, a verification message is given that provides an opportunity to cancel the deletion. If the analysis to be deleted is referred to by another analysis for its input, the verification message indicates this fact.
  • Log Analysis Info <Analysis> — Information about the currently selected analysis that might be useful for support purposes is written to the information log. The log can be viewed by selecting the Tools > View Logs - View Info Log… option.
  • Extract SQL — This option extracts the generated SQL from the results of the currently selected analysis, or from all of a project's analyses if a project is currently selected, placing the SQL in a display so that it can be reviewed, edited, copied, written to a file or placed in a Free Form SQL test node. When the SQL from an entire project is extracted, headers are added as comments to identify the beginning of the SQL for each included analysis.
    The Extract SQL dialog can remain open and change display when a different project or analysis is selected in the project window. Further, the Write button can be used to create an SQL file for several projects or analyses successively without closing the dialog.
    It is important to note that SQL is not extracted from the results of every analysis. There are several reasons why SQL might not be extracted from an analysis:
    1. The analysis may not have been executed yet.
    2. It may be a type of analysis that does not store SQL in its results, including Scatter Plot and Matrix analyses, analytic algorithms other than Association, and Scoring analyses that do not have the Score Only option selected.
    3. When extracting SQL from an entire project, the SQL from an analysis that has been refreshed or published is not included in the extracted SQL.
    4. When extracting SQL from an entire project, any analysis marked as Skip during Project Execution does not have SQL extracted.
    5. When extracting SQL from an entire project, any SQL generated for a derived table, subquery or With query is not extracted because it is already included in its referencing analysis.
    6. When extracting SQL from an entire project, any SQL generated by a Publish analysis is not included because it is not in an executable form (i.e., it includes special substitution tags).
    The following information is displayed by the Extract SQL dialog.
    • Extracted SQL file — The full path of the file containing the extracted SQL is displayed here after the Write button has been selected and the file has been written.
    • Number of statements extracted — The total number of SQL statements extracted. Note that some analyses generate more than one SQL statement.
    • Number of characters extracted — The total number of characters in the extracted SQL, including the headers added to identify analyses when extracting SQL for an entire project.
    • Analyses in Project — The total number of analyses in a project is displayed if and only if a project is currently selected.
    • Analyses displaying SQL — The number of analyses which contained results SQL is displayed if and only if a project is currently selected.
      The following options are provided:
      • Display default procedure CALL in place of procedure SQL — When this box is checked, an SQL CALL statement is displayed in place of the SQL to create a stored procedure. As close as possible, the values of the parameters in the CALL statement are set equal to the values that would be in effect if the underlying analysis was executed without creating a procedure.

        This option is given for an analysis only if the analysis creates a stored procedure, and for a project only if the project contains at least one such analysis.

        Anchor table parameters may appear in a default procedure call as artificial “tags” (beginning with '_twm') if there is no replaceable, non-volatile anchor table.

      • Edit SQL — When this check box is checked, the displayed SQL can be edited prior to writing, copying or testing. Using this option "locks" the dialog display so that it will not change if another project or analysis is selected.
      • Word Wrap — When this check box is checked, the SQL is displayed in a way such that the statements have their text wrap to the next line if they do not fit into the window.
      • Up and Down Arrows — The up and down arrows may be used to position the display to the previous or next analysis when the SQL for an entire project is displayed.
      • Test Node — Selecting the Test Node button creates a Free Form SQL analysis containing the extracted SQL and marks the analysis as Skip during Project Execution. This can be used to test the displayed SQL.
      • Write — Selecting the Write button leads to a dialog to locate, name and write to a file the SQL displayed on the form. This will include any programmatically added analysis headers or user edited changes.
      • Right-Click Menu Options — The standard right-click menu options are provided in the SQL display area, including Undo, Redo, Cut, Copy, Paste, Delete, Find, Replace and Select All. Not all options may be enabled depending on whether the Edit SQL box is checked and whether there is displayed text and a history of actions to be undone or redone.
  • Create Results Files — This option enables the creation of tab-delimited files from the result sets of a selected analysis or project in the Project Area. A dialog is displayed to enable the selection of a destination folder for the files, along with options to write, view and export them to Excel.
    The Results menu offers an option to export results to Excel, so this option is simply a convenience to make it easier to keep track of created files and to create them for lots of analyses at once.

    Most types of analysis produce results from the SQL they generate and execute. However, here are some reasons why a results file may not be created for a particular analysis.

    • The analysis may not have been executed yet.
    • It may be a type of analysis that does not produce results data, particularly Scatter Plot and most Matrix analyses, and analytic algorithms other than Association.
    • There is no results data from any executed analysis marked as “Generate SQL Only”.
    • There is no results data from an analysis that has been published.
    • There is no results data from a Refresh or Publish analysis.
    • There is no results data from an analysis that is referenced as a volatile table.
    • There is no results data when creating a stored procedure.

      Here are some other characteristics of this feature.

    • If an analysis creates multiple results sets, they are all written to the same file with blank lines in between.
    • Result sets with no rows are not written to a file.
    • Result set columns are separated by an added tab character, and character data is enclosed in double-quotes.
    • Each result set file name is taken from the name of the analysis that produced the result set, with illegal filename characters replaced with space characters.
    • A warning is given if processing a project that contains analyses with duplicate names.
    • A warning is given if any of the file names about to be created already exist in the destination folder.
    • An option is provided to export all of the files or those that are selected to Excel. Each file becomes a separate window in the work area.
  • Create SQL Node to Drop Tables — This option creates in the current project a Free Form SQL analysis containing statements to drop every table and view created in the currently selected project or analysis.
  • Create SQL Node to Collect Statistics — This option creates in the current project a Free Form SQL analysis containing statements to collect statistics on the primary index of every table created in the currently selected project or analysis.
    If an output table does not exist, the primary index columns will not be known and the SQL to collect statistics on that table will be incomplete, which will be noted in a comment after the command.
  • Properties — The Properties dialog may be displayed for the currently selected project or analysis by selecting this option, as described below.

    When a project is selected in the project window, the Properties option may be selected from the Project menu or by right-clicking on the project to display the Project Properties dialog. When an analysis is selected, the Analysis Properties dialog may be similarly displayed, with the differences noted in the descriptions that follow. Note that the same Properties display can be requested from the Metadata Maintenance screen, available from the Tools menu.

    The Properties dialog can remain open and change display when a different project or analysis is selected in the project window. Further, the Apply button can be used to enter a Description for several projects or analyses successively without closing the dialog.

    The Analysis Properties dialog displays a Name and Type field instead of Project Name. It also displays a third tab, References, that provides an outline of analysis references and dependencies.

    Description — The description of the project or analysis may be entered here.

    Usage Info tab — The Usage Info tab displays information about the creation, modification and execution of the project or analysis.

    Parameters tab — The Parameters tab, when selected for an analysis, contains the same information which would be logged to the Info Log file if the Log Analysis Info option were to be selected from the Project menu (or by right-clicking on an analysis in the Project window and selecting the same option). When selected for a project, summary information is displayed.

    References tab — The References tab outlines analysis references and dependencies and is available only when displaying the Analysis Properties dialog. Here is a summary of relationships outlined on this tab:

    • References for input — This indicates that the listed analyses are referenced for input using the analysis references feature or a facsimile of it (as is the case with the Free Form SQL analysis). Note that the display indicates not only referenced analyses, but any analyses that these analyses may reference, or that these analyses may reference, and so forth. Indention is used in the display for this purpose.
    • Is referenced by — Indicates that the output of this analysis is referenced for input by the listed analysis. In the case where Refresh or Publish is the referencing analysis, it might be said rather that the generated SQL is referenced rather than the output. Only one level of references is displayed for this relationship.
    • Depends on analysis — Indicates that this analysis depends on the indicated analysis in some way other than using the output table or view as input. This case includes an algorithm dependent on a matrix, or a scoring analysis dependent on an algorithm.
    • Is depended on by — Indicates that this analysis is depended on by the indicated analysis in some way other than an output table or view being used as input. This case includes an algorithm dependent on a matrix, or a Scoring analysis dependent on an algorithm.
  • Display names of output tables, views and procedures… — When this option is checked, the dialog expands to list these objects. Note that each type of object is distinguished by a different icon. Note also that in the case of Project Properties, this extended display lists the potential output tables, views and procedures created by all of the analyses contained in the project.
  • Show Object — This button attempts to display the definition of the selected table, view or procedure, provided that only one object is selected.
    This button is only available when connected to a Teradata system.
  • Drop Objects — This button attempts to delete the selected tables, views and/or procedures from the database containing them.
    On a Teradata system, the names are displayed in the format Database.Table, Database.View or Database.Procedure. On an Aster system, the names are displayed in the format Schema.Table, Schema.Table or Schema.Procedure.

    The box displaying the object names changes to indicate a status and possible error message. The status will indicate whether or not the selected table or view was DROPPED or NOT FOUND (it may never have been created or it may have subsequently been dropped), or whether an ERROR occurred, in which case an error message is also displayed. Note that the columns in this display may be resized by dragging the vertical bars in the column header with the mouse.

  • Collect Statistics — This button attempts to collect statistics on the primary index of the selected tables. Note that statistics cannot be collected on a view or procedure. The box displaying the object names changes to indicate a status and possible error message. The status will indicate whether or not the selected table statistics were COLLECTED, the table was NOT FOUND, the item was SKIPPED (due to its not being a table or due to a failure to determine the primary index), or whether an ERROR occurred, in which case the error message is also displayed. Note that the columns in this display may be resized by dragging the vertical bars in the column header with the mouse.
  • OK/Cancel/Apply — The OK button accepts any changes that may have been made to an editable field and closes the dialog. The Cancel button discards any changes that may have been made and likewise closes the dialog. The Apply button is only enabled if changes have been made and simply saves the changes and keeps the dialog open.
    When this dialog is displayed from within Metadata Maintenance, the Cancel and Apply buttons do not appear, because no fields may be edited in this case.