QueryGrid Connector to Apache Hive | Teradata QueryGrid - 2.15 - Teradata QueryGrid to Apache Hive Connector - Teradata QueryGrid

Teradata® QueryGrid™ Components and Connectors Compatibility Matrix

prodname
Teradata QueryGrid
vrm_release
2.06
2.07
2.08
2.09
2.10
2.11
2.12
2.13
2.14
2.15
category
Configuration
Installation
featnum
B035-5993-000K
Amazon Elastic Map Reduce (EMR) QueryGrid
2.15.00.00 2.14.00.00+ 2.13.00.00+ 2.12.00.00+ 2.11.00.03+
EMR 5.29 Yes Yes Yes Yes Yes
Azure HDInsight (HDI) QueryGrid
2.15.00.00 2.14.00.00+ 2.13.00.00+ 2.12.00.00+ 2.11.00.00+ 2.10.00.00+ 2.09.00.00+
HDI 4.0 Yes Yes Yes
HDI 3.6 Yes Yes Yes Yes Yes Yes
Supported HDInsight cluster types are Hadoop, Interactive Query, and Spark.
Google Cloud Dataproc (Dataproc) QueryGrid
2.15.00.00 2.14.00.00+
Dataproc 1.4 Yes Yes
Cloudera Distributed Hadoop (CDH) QueryGrid
2.15.00.00 2.14.00.00+ 2.13.00.00+ 2.12.00.00+ 2.11.00.00+ 2.10.00.00+ 2.09.00.00+ 2.08.00.00+ 2.07.00.02+ 2.06.00.01+
CDH 6.3 Yes Yes Yes Yes Yes
CDH 6.2 Yes Yes Yes Yes Yes Yes
CDH 5.16 Yes Yes Yes Yes Yes Yes Yes Yes
CDH 5.15 Yes Yes Yes Yes Yes Yes Yes Yes Yes
CDH 5.14 Yes Yes Yes Yes Yes Yes Yes Yes Yes
CDH 5.13 Yes Yes Yes Yes Yes Yes Yes Yes Yes
CDH 5.12 Yes Yes Yes Yes Yes Yes Yes Yes Yes
CDH 5.11 Yes Yes Yes Yes Yes Yes Yes Yes Yes
Hortonworks Data Platform (HDP) QueryGrid
2.15.00.00 2.14.00.00+ 2.13.00.00+ 2.12.00.00+ 2.11.00.00+ 2.10.00.00+ 2.09.00.00+ 2.08.00.00+ 2.07.00.02+ 2.06.00.01+
HDP 3.1.5 Yes Yes
HDP 3.1.4 Yes Yes Yes Yes Yes Yes
HDP 3.0.1 Yes Yes Yes Yes Yes Yes Yes Yes Yes
HDP 2.6.5 Yes Yes Yes Yes Yes Yes Yes Yes Yes
HDP 2.6.4 Yes Yes Yes Yes Yes Yes Yes Yes Yes
HDP 2.6.2 Yes Yes Yes Yes Yes Yes Yes Yes Yes
HDP 2.6.1 Yes Yes Yes Yes Yes Yes Yes Yes Yes
HDP 2.6.0 Yes Yes Yes Yes Yes Yes Yes Yes Yes
  • Hot fix required for HDP 2.6.5. For more information, see Tech Alert ID: NTA-4475 at KAC1502EA.
  • LLAP requires Apache Hive version 2.1 on HDP 2.6.0 or later.
  • Hadoop distributions and distribution versions not listed are not certified or supported.