15.11 - Setting the Compiler Compliance Level - Teradata Studio

Teradata Studio, Studio Express, and Plug-in for Eclipse Installation Guide

prodname
Teradata Studio
vrm_release
15.11
created_date
May 2016
category
Administration
Installation
featnum
B035-2037-056K
Teradata Database 15.11 supports JRE 1.6. However, Teradata Database versions earlier than 14.0 support only JRE version 1.5. Because Teradata Plug-in for Eclipse requires JRE 1.6 (jre6), if you are connecting to a Teradata Database version earlier than 14.0 the compiler compliance level must be set to 1.5 to create Java stored procedures or Java functions compatible with Teradata Database. When creating a Teradata Project, an option for the JRE execution environment appears:
  1. In the Teradata Project Wizard, select Use and execution environment JRE and click JRE-1.6.