16.10 - Recovering from Failure during the DSC Repository Upgrade - Data Stream Utility

Data Stream Utility Installation, Configuration, and Upgrade Guide for Customers

prodname
Data Stream Architecture
Data Stream Utility
vrm_release
16.10
created_date
August 2017
category
Configuration
Installation
featnum
B035-3153-087K
  1. Drop the BAR and BARBACKUP databases, by running the following commands in BTEQ: delete database BAR; drop database BAR; delete database BARBACKUP; drop database BARBACKUP;
  2. Re-install the previous version. The repository is corrupt so it must be recovered to the previous version before attempting the upgrade again.
  3. From the DSA installation directory, import the configuration file you exported before the upgrade (step 2 of Backing Up the DSC Repository and Configuration When Upgrading). dsc import_repository_backup_config -f export_repository_backup_config.xml
  4. If SSL is not enabled for this system, restart the ClientHandler.
  5. If SSL is enabled for this system, perform the following in the BAR Setup portlet:
    1. From the CATEGORIES list, click Systems and Nodes and select the repository.
    2. Select the Enable SSL over JMS Communication checkbox and enter the TrustStore password.
    3. Click Apply and enter the credentials when prompted.
    4. Restart DSMain on the DSC repository system as indicated in the warning message.
    5. From the CATEGORIES list, click Media Servers, select the media server used for repository backup, and click Apply. This activates the media server in the background.
  6. Recover saveset information: dsc recover_backup_metadata -n repository_target_group
  7. Run a repository restore job using the BAR Setup portlet or the run_repository_job command. dsc run_repository_job -t restore
  8. Perform a tpareset to the DSC repository database.
  9. [Optional] Re-attempt the upgrade.