15.10 - Preview Mode - Teradata Administrator

Teradata Administrator User Guide

prodname
Teradata Administrator
vrm_release
15.10
category
User Guide
featnum
B035-2502-035K

Use Preview mode to view the generated SQL text in a Query window before submitting it for processing. The displayed SQL can be changed before submitting it to the Teradata Database or cancelled without submitting it. Preview mode can also be used to generate scripts for later execution or as a learning tool for the DBA.

Preview mode can be used with all Create, Modify, Grant, and Revoke commands. It can also be used when adding or removing members from a role and when moving space. Preview mode cannot be used for Drop or View commands.

Note: Although Comment commands are not displayed in the Query window, if a comment is added or changed in dialog boxes from the Tools menu, it is submitted even if Preview mode is on. It is even submitted if the Query window is closed without executing the query.

  • Do one of the following to turn Preview mode on:
  • From the toolbar, click .
  • From the menu, click Tools > Options or press F4 from any open dialog box from the Tools menu, then click the Confirmation tab, and select the Preview SQL before submitting it check box.
  • When Preview mode is on:

  • The SQL (generated by dialog boxes from the Tools menu) is displayed in a Query window instead of automatically being executed.
  • Objects that are created by executing the preview query are not automatically added to or removed from any list. To update the lists, click Window > Refresh to reload the data from the Teradata Database.
  • Executing Multiple Statements

    Teradata Administrator executes the entire contents of the Query window as a single request. However, the Teradata Database does not process requests containing multiple DDL statements. When the generated query contains multiple DDL statements, such as adding or removing more than 25 members to a role or when moving space between unrelated databases, the Execute button is unavailable.

  • Do one of the following:
  • Turn Preview mode off and re‑execute the command.
  • Paste the statements into Teradata SQL Assistant or BTEQ to process.