Project Area - Teradata Warehouse Miner - 5.4.4

Teradata Warehouse Miner User Guide - Volume 1Introduction and Profiling

prodname
Teradata Warehouse Miner
vrm_release
5.4.4
category
User Guide
featnum
B035-2300-077K

The Project Area displays all currently loaded projects and their analyses and attachments, if any. To hide the Project Area, click on the X in the upper right hand portion of the window. To show the Project Area, select the left-arrow button that is displayed just above the Project Area when closed or select the View > Project Window option. If the Project Area is currently hidden, this will make it visible.

Selecting an analysis in the Project Area will not only highlight the selected analysis, but each analysis that the selected analysis references for input, directly or indirectly, temporarily italicizing the name of each referenced analysis. Similarly, each analysis that the selected analysis depends on (such as a scoring analysis depending on an algorithm) is also highlighted with the analysis name temporarily underlined. Note that when an individual selected analysis is executed, referenced analyses with italicized names will be executed first, whereas dependent analyses with underlined names will not be automatically executed.

When a project is selected, the following right-click menu options are available.
  • View — View the currently selected project.
  • Run — Run the currently selected project within the project window. Alternately, using the function F5 key can execute a selected project as well.

    To execute a project, each analysis in the project is executed in order with the exception that before each analysis is executed, each analysis that it may refer to as the source of its input is automatically executed first. This is done in such a way however that each analysis in a project is only executed once.

  • Stop — Stop the currently running and selected project.
  • Add New Analysis… — Add a new analysis to the project.
  • Add Existing Analysis … — Add copies of one or more existing analyses to the currently selected project. For more information, see Adding Analyses to a Project.
  • Add Attachment … — Create an attachment folder within the specified project and copy any valid windows object into it, such as a document file.
  • Save <project name> — Save the specified project and its contents. If another user has saved the same project in another session after the project was last saved or opened in this session, a message is given, along with an option to save a copy of the project, but it is not allowed to overwrite the original project in this case.
  • Save <project name> As — Save the specified project and its contents under a new name. Note that this option creates a new project containing copies of all analyses within the current project.
  • Save <project name> and Archive — Save the specified project and its contents along with archiving the project to an export file in the standard automatic archive. (The automatic archive facility is described in Metadata Maintenance, specifically in the portion describing the Archive button.)
  • Save All Projects — Save all of the currently open projects and their contents.
  • Close <project name> — Close the specified project.
  • Close All Projects — Close all projects that are open in the workspace.
  • Delete — Delete the currently selected project within the project window. Before the project is deleted, a verification message is given that provides an opportunity to cancel the deletion.
  • Rename — Rename the specified project.
  • Export… — Display the Export Wizard in order to save the currently selected project to a binary file for possible retrieval on the same or different system using the Import Wizard.
  • Extract SQL — This option extracts the generated SQL from the results of all the analyses contained in the project, placing it in a display so that it can be reviewed, edited, copied, written to a file or placed in a Free Form SQL test node. For more information, see the description of the Extract SQL option in Project Menu.
  • Create Results Files — This option enables the creation of tab-delimited files from the result sets of all of the analyses in a project. A dialog is displayed to enable the selection of a destination folder for the files and to watch the progress of the building of the result files, along with an option to export selected result sets to Excel. For more information, see the description of the Create Results Files option in Project Menu.
  • Create SQL Node to Drop Tables — This option creates a Free Form SQL analysis in the current project that contains statements to drop every table and view created in the currently selected project or analysis.
  • Create SQL Node to Collect Statistics — This option creates a Free Form SQL analysis in the current project that contains statements to collect statistics on the primary index of every table created in the currently selected project or analysis.

    Note that if an output table does not exist, the primary index columns will not be known and the SQL to collect statistics on that table will be incomplete, which will be noted in a comment after the command.

  • Properties — The Properties dialog may be displayed for the currently selected project or analysis by selecting this option, as described below.
When an Analysis is selected, the following right-click menu options are available.
  • View — View the currently selected analysis.
  • Run — Run the currently selected analysis within the project window. Alternately, using the function F5 key can execute a selected analysis as well.

    Before an analysis is executed, each analysis that it may refer to as the source of its input is automatically executed first. Since a referenced analysis may refer to other analyses as well, executing an individual analysis may result in the execution of a series of analyses.

  • Run To End — Run the currently selected analysis within the project window followed by each of the subsequent analyses until the end of the project. Alternately, using the function F6 key can execute a selected analysis and subsequent analyses as well.

    Note that execution order may be affected when an analysis refers to another analysis in the project for its input, in which case the referenced analysis is always executed before the analysis that refers to it. No analysis is executed more than once.

  • Run Stand-Alone — Run the currently selected analysis within the project window without executing any analyses that it may reference for input. Alternately, using the function F7 key can execute a selected analysis as well.

    Note that this option may result in an error if an analysis referenced for input has not created the required input table or if a created volatile table is no longer available.

    This option may be ignored in the Teradata Profiler product.

  • Skip during Project Execution — Use this option to skip the execution of an individual analysis when the project that contains it is executed, whether in whole or in part when the Run to End option is used. It does not, however, skip the execution of an analysis that is executed by itself or as the result of being referenced by another analysis that is being executed by itself. The option works by toggling a flag that is saved with the analysis and is honored both in subsequent interactive and batch executions.

    Skipping the execution of an analysis during project execution may be useful in many instances. For example, the option can be used to avoid rebuilding a matrix every time an algorithm that uses it is executed to build a model, or similarly to avoid rebuilding a model every time an analysis that scores it is executed. Similarly, it can be used to avoid executing a chain of analyses an extra time when they are being refreshed or published with the Refresh or Publish analysis, respectively.

  • Stop — Stop the currently running and selected analysis.
  • Delete — Delete the currently selected analysis within the project window. Before the analysis is deleted, a verification message is given that provides an opportunity to cancel the deletion. If the analysis to be deleted is referred to by another analysis for its input, the verification message indicates this fact.
  • Delete without archiving/Delete after archiving — This option allows the user to override the current setting of the preference option to Automatically archive deleted projects, analyses etc. when deleting the currently selected analysis. If the automatic archive preference option is checked, this option reads Delete without archiving, and if not checked this option reads Delete after archiving. Otherwise, the Delete option is performed as described above.
  • Rename — Rename the specified analysis.
  • Export… — Display the Export Wizard in order to save the currently selected analysis to a binary file for possible retrieval on the same or different system using the Import Wizard.
  • Clone — Make a copy of the currently selected analysis and insert it into the project just after the analysis being copied.
  • Move to Top — Move the selected analysis to the top of the project's list of analyses.
  • Move to Bottom — Move the selected analysis to the bottom of the project's list of analyses.
  • Log Analysis Info — Information about the currently selected analysis that might be useful for support purposes is written to the information log. The log can be viewed by selecting the Tools > View Logs - View Info Log… option.
  • Extract SQL — Extract the generated SQL from the results of the selected analysis, placing it in a display so that it can be reviewed, edited, copied, written to a file or placed in a Free Form SQL test node. For more information, see the description of the Extract SQL option in Project Menu.
  • Create Results Files — Enable the creation of tab-delimited files from the result sets of a selected analysis. A dialog appears that lets you enable the selection of a destination folder for the files along with an option to export the result set(s) of the selected analysis to Excel. For more information, see the description of the Create Results Files option in Project Menu.
  • Create SQL Node to Drop Tables — Create a Free Form SQL analysis in the current project that contains statements to drop every table and view created in the currently selected project or analysis.
  • Create SQL Node to Collect Statistics — Create a Free Form SQL analysis in the current project that contains statements to collect statistics on the primary index of every table created in the currently selected project or analysis.

    If an output table does not exist, the primary index columns will not be known and the SQL to collect statistics on that table will be incomplete, which will be noted in a comment after the command.

  • Properties — The Properties dialog may be displayed for the currently selected project or analysis by selecting this option, as described below.
When an Attachment is selected, the following right-click menu options are available.
  • View — View the currently selected attachment (i.e., the attachment is opened with the appropriate program based on association with the files extension, such as .txt).
  • Delete — Delete the currently selected attachment.
  • Rename — Rename the currently selected attachment.
  • Export… — Display the Export Wizard in order to save the currently selected attachment to a binary file for possible retrieval on the same or different system using the Import Wizard.
When an Attachment folder is selected, the following right-click menu options are available.
  • Add Attachment … — A file may be selected and added to the project's Attachment Folder.
  • Export… — Display the Export Wizard in order to save all of the attachments in the selected Attachment folder to a binary file for possible retrieval on the same or different system using the Import Wizard.